- Do not pass SVN_REV via CFLAGS, it is now defined in `src/d_main.c' - OLD_DEPENDENCIES is no longer a valid setting, stop referencing it - When adjusting default WAD search path, fix only one DEFWADS rather than a bunch of them (one is enough) - Remove old hack for better support for relative paths (for `-iwad' switch): it no longer applies and the game works correctly per se - Remove Clang-related fixes that were integrated upstream - Do not overwrite `make_options' file, simply append few necessary settings at the end of it List of changes: http://doomlegacy.sourceforge.net/docs/whatsnew.html
34 lines
1 KiB
Text
34 lines
1 KiB
Text
--- src/Makefile.orig 2017-01-01 23:32:38 UTC
|
|
+++ src/Makefile
|
|
@@ -577,7 +577,7 @@ ifeq ($(SMIF), SDL)
|
|
# default is Linux, for all unix SDL
|
|
EXENAME:=doomlegacy
|
|
LDFLAGS=-L/usr/X11R6/lib
|
|
- LIBS:=-lGL -lGLU -lm
|
|
+ LIBS:=-lGL -lGLU -lm -lipx
|
|
# -L/usr/X11R6/lib is needed by Linux 2.4 and others that still have
|
|
# the GLU libraries in an X11 directory.
|
|
# -lm is needed for pow, powf, and other MATH1 functions.
|
|
@@ -963,7 +963,7 @@ ifdef CDMUS
|
|
endif
|
|
|
|
# compiler and linker flags
|
|
-CFLAGS:=$(WFLAGS)
|
|
+#CFLAGS:=$(WFLAGS)
|
|
|
|
ifdef PROFILEMODE
|
|
# build with gprof profiling information
|
|
@@ -980,11 +980,11 @@ ifdef DEBUG
|
|
else
|
|
# build a normal optimized version
|
|
#CFLAGS+=-O3
|
|
- CFLAGS+=$(OPTLEV) -fomit-frame-pointer
|
|
+ #CFLAGS+=$(OPTLEV) -fomit-frame-pointer
|
|
endif
|
|
endif
|
|
|
|
-CFLAGS+=-ffast-math -fno-strict-aliasing
|
|
+#CFLAGS+=-ffast-math -fno-strict-aliasing
|
|
# WIN98 linking needs LCFLAGS without -D flags and does not need includes
|
|
LCFLAGS:=$(CFLAGS)
|
|
CFLAGS+=$(OPTS) $(OPTINC)
|