freebsd-ports/irc/quassel/files/patch-CMakeLists.txt
Ben Woods 896e7d8294 irc/quasssel: Patch CMakeLists.txt to fix build against SSL with Qt 5.6
PR:		213581
Submitted by:	Christian Schwarz (me@cschwarz.com)
Submitted by:	tcberner
Reviewed by:	mat
Approved by:	adamw (mentor, implicit)
Obtained from:	4768c9e99f
MFH:		2016Q4
Differential Revision:	https://reviews.freebsd.org/D8294
2016-10-27 15:34:56 +00:00

19 lines
696 B
Text

From 4768c9e99f99b581d4e32e797db91d0182391696 Mon Sep 17 00:00:00 2001
From: martin <martin.sandsmark@kde.org>
Date: Tue, 7 Jun 2016 00:37:22 +0200
Subject: [PATCH] Fix the SSL check with Qt 5.6 and GCC 5 (#199)
--- CMakeLists.txt.orig 2016-04-24 20:36:58 UTC
+++ CMakeLists.txt
@@ -428,6 +428,11 @@ endif()
cmake_push_check_state(RESET)
set(CMAKE_REQUIRED_INCLUDES ${QT_INCLUDES} ${Qt5Core_INCLUDE_DIRS})
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5Core_EXECUTABLE_COMPILE_FLAGS}")
+
+if (USE_QT5 AND Qt5_POSITION_INDEPENDENT_CODE)
+ set(CMAKE_REQUIRED_FLAGS "-fPIC -DQT_NO_VERSION_TAGGING")
+endif()
+
check_cxx_source_compiles("
#include \"qglobal.h\"
#if defined QT_NO_SSL