8d850ed6c5
print/hplip: - Add LICENSE details - Changes USE_OPENSSL=yes to USES=ssl - Create empty directories for pkg-plist @dir entries - Reformat patches with makepatch (pet portlint) - Move ${PREFIX}/etc/sane.d/dll.conf to ${PREFIX}/etc/sane.d/dll.d/hpaio during post-install, rather than editing ${PREFIX}/etc/sane.d/dll.conf during @exec and @unexec during pkg-plist print/hplip-plugin: - Re-order LICENSE block (pet portlint) Changes this release: http://hplipopensource.com/hplip-web/release_notes.html Reviewed by: mat (mentor) Approved by: makc (maintainer timeout), adamw (mentor) Differential Revision: https://reviews.freebsd.org/D7812
24 lines
994 B
Python
24 lines
994 B
Python
--- installer/dcheck.py.orig 2016-08-26 10:05:26 UTC
|
|
+++ installer/dcheck.py
|
|
@@ -48,7 +48,11 @@ mod_output = ''
|
|
def update_ld_output():
|
|
# For library checks
|
|
global ld_output
|
|
- status, ld_output = utils.run('%s -p' % os.path.join(utils.which('ldconfig'), 'ldconfig'), log_output=False)
|
|
+ if sys.platform.startswith('freebsd'):
|
|
+ ld_cmd = '%s -r'
|
|
+ else: # linux
|
|
+ ld_cmd = '%s -p'
|
|
+ status, ld_output = utils.run(ld_cmd % os.path.join(utils.which('ldconfig'), 'ldconfig'), log_output=False)
|
|
|
|
if status != 0:
|
|
log.debug("ldconfig failed.")
|
|
@@ -378,6 +382,8 @@ def get_libpthread_version():
|
|
except ImportError:
|
|
return '-'
|
|
else:
|
|
+ if sys.platform.startswith('freebsd'):
|
|
+ return '-'
|
|
# LIBC = ctypes.CDLL(ctypes.util.find_library('c'), use_errno=True)
|
|
LIBC = ctypes.CDLL(ctypes.util.find_library('c'),ctypes.DEFAULT_MODE,None, True)
|
|
LIBC.gnu_get_libc_version.restype = ctypes.c_char_p
|