1f53fed603
and test it you need the following (5-CURRENT only, BTW): - fetch a patch for libvgl: http://people.freebsd.org/~sobomax/libvgl.patch, apply it, recompile/reinstall libvgl; - recompile/reinstall sdl-devel (configure script automatically detects if right version of libvgl is present); - set environment variable SDL_VIDEODRIVER=vgl; - ensure that you have VESA support compiled into kernel or loaded as a kld; - fire up your favourite SDL app ;).
21 lines
439 B
Text
21 lines
439 B
Text
|
|
$FreeBSD$
|
|
|
|
--- /dev/null Sun Jan 21 22:16:58 2001
|
|
+++ src/video/vgl/Makefile.am Sun Jan 21 22:04:06 2001
|
|
@@ -0,0 +1,15 @@
|
|
+
|
|
+## Makefile.am for SDL using the libVGL video driver
|
|
+
|
|
+noinst_LTLIBRARIES = libvideo_vgl.la
|
|
+libvideo_vgl_la_SOURCES = $(VGL_SRCS)
|
|
+
|
|
+# The SDL libVGL video driver sources
|
|
+VGL_SRCS = \
|
|
+ SDL_vglvideo.h \
|
|
+ SDL_vglevents.c \
|
|
+ SDL_vglevents_c.h \
|
|
+ SDL_vglmouse.c \
|
|
+ SDL_vglmouse_c.h \
|
|
+ SDL_vglvideo.c
|
|
+
|