d1c2f0dddd
original versions of these ports, so some PORTREVISIONs were bumped. See http://freebsd.kde.org/ and mailing lists linked to from there for info on the packages generated to test these ports. bsd.kde.mk has already been updated a few days ago to work with these. Some patches applied to fix a few bugs were: deskutils/kdepim3: [1] Remove kpilot from build because it wasn't ready at release. editors/koffice-kde3: [2] Fix compile time bugs for FreeBSD. misc/kdeedu3: [3] Fix compile problem with kvoctrain. x11/kdebase3: [4] Fix KDM CPU usage and login bug. Some caveats: * All PLISTs are broken for deinstall due to script bug that I didn't notice until very recently. This will be fixed when I commit an update tomorrow. These ports should still install perfectly fine though. They should also deinstall without giving errors, but will leave directories behind. * You can't install this with any other version of QT or KDE already installed. I am not sure the checks are 100% working, but fixes for these will be forthcoming. This is mainly due to a policy decision made by kde@ to make QT/KDE ports install the way the rest of the world expects it to while also still conforming to FreeBSD's hier(7). For reference on this decision, please consult the KDE/FreeBSD mailing list archives. This decision fixes 2-year-old bug reports relating to how we handled this for KDE2 vs KDE1. Submitted by: [1] Adrian de Groot <adridg@cs.kun.nl>, [2] David Faure <faure@kde.org>, Andy Fawcett <andy@athame.co.uk> Lauri Watts <lauri@kde.org> [3] Lauri Watts <lauri@kde.org> [4] Alan Eldridge <alane@geeksrus.net> Oswald Buddenhagen <ossi@kde.org> Reviewed by: kde
19 lines
448 B
C
19 lines
448 B
C
--- ./kdm/backend/dm.c.orig Sun Mar 24 12:31:09 2002
|
|
+++ ./kdm/backend/dm.c Thu Apr 18 20:53:44 2002
|
|
@@ -236,7 +236,6 @@
|
|
else
|
|
break;
|
|
}
|
|
- InitErrorLog (errorLogFile);
|
|
|
|
/*
|
|
* Only allow root to run in non-debug mode to avoid problems
|
|
@@ -246,6 +245,8 @@
|
|
fprintf (stderr, "Only root wants to run %s\n", prog);
|
|
exit (1);
|
|
}
|
|
+
|
|
+ InitErrorLog (errorLogFile);
|
|
|
|
/*
|
|
* Step 1 - load configuration parameters
|