c3f03316b9
- This update also resolves functional problems of PR 148238 and 147970 PR: ports/149940 PR: ports/148238 PR: ports/147970 Approved by: itetcu (mentor, implicit), maintainer Submitted by: mike@sentex.net, maintainer Security: 167953a4-b01c-11df-9a98-0015587e2cc1 Security: http://www.openwall.com/lists/oss-security/2010/08/24/3
57 lines
1.6 KiB
Text
57 lines
1.6 KiB
Text
--- configure.ac.orig 2010-08-19 11:36:29.000000000 +0200
|
|
+++ configure.ac 2010-08-25 09:06:04.000000000 +0200
|
|
@@ -443,20 +443,6 @@
|
|
#endif /* TIME_WITH_SYS_TIME */
|
|
])dnl
|
|
|
|
-AC_CHECK_HEADERS([sys/un.h net/if.h netinet/in_systm.h netinet/in_var.h \
|
|
- net/if_dl.h net/if_var.h net/netopt.h net/route.h \
|
|
- inet/nd.h arpa/inet.h netinet/ip_icmp.h \
|
|
- fcntl.h stddef.h sys/ioctl.h syslog.h wchar.h wctype.h \
|
|
- sys/sysctl.h sys/sockio.h kvm.h sys/conf.h],
|
|
- [], [], QUAGGA_INCLUDES)
|
|
-
|
|
-AC_CHECK_HEADERS([ucontext.h], [], [],
|
|
-[#ifndef __USE_GNU
|
|
-#define __USE_GNU
|
|
-#endif /* __USE_GNU */
|
|
-QUAGGA_INCLUDES
|
|
-])
|
|
-
|
|
m4_define([QUAGGA_INCLUDES],
|
|
QUAGGA_INCLUDES
|
|
[#if HAVE_NET_IF_H
|
|
@@ -474,9 +460,6 @@
|
|
#if HAVE_NET_IF_DL_H
|
|
# include <net/if_dl.h>
|
|
#endif
|
|
-#if HAVE_NET_IF_VAR_H
|
|
-# include <net/if_var.h>
|
|
-#endif
|
|
#if HAVE_NET_NETOPT_H
|
|
# include <net/netopt.h>
|
|
#endif
|
|
@@ -493,8 +476,23 @@
|
|
#if HAVE_NETINET_IP_ICMP_H
|
|
# include <netinet/ip_icmp.h>
|
|
#endif
|
|
+#include <security/pam_types.h>
|
|
])dnl
|
|
|
|
+AC_CHECK_HEADERS([sys/un.h net/if.h net/if_var.h net/if_dl.h \
|
|
+ netinet/in_systm.h netinet/in_var.h net/netopt.h net/route.h \
|
|
+ inet/nd.h arpa/inet.h netinet/ip_icmp.h \
|
|
+ fcntl.h stddef.h sys/ioctl.h syslog.h wchar.h wctype.h \
|
|
+ sys/sysctl.h sys/sockio.h kvm.h sys/conf.h],
|
|
+ [], [], QUAGGA_INCLUDES)
|
|
+
|
|
+AC_CHECK_HEADERS([ucontext.h], [], [],
|
|
+[#ifndef __USE_GNU
|
|
+#define __USE_GNU
|
|
+#endif /* __USE_GNU */
|
|
+QUAGGA_INCLUDES
|
|
+])
|
|
+
|
|
dnl V6 headers are checked below, after we check for v6
|
|
|
|
dnl Some systems (Solaris 2.x) require libnsl (Network Services Library)
|