freebsd-ports/www/apache22/files/patch-configure.in
Philip M. Gollucci 63e45c24e6 - Regenerate patch files with make makepatch for they have
piled up and additional patches conflict.
  This also will help when we try to syncronize www/apache20&www/apache22
- Unconditionally apply the mod_proxy_connect patch, you just may or may
  not actually compile the file to save some logic in Makefile

With Hat:   apache@
2010-05-07 00:02:16 +00:00

54 lines
2.3 KiB
Text

--- ./configure.in.orig 2008-12-01 15:32:43.000000000 -0500
+++ ./configure.in 2010-05-06 19:37:54.216730223 -0400
@@ -87,9 +87,14 @@
AC_MSG_ERROR([APR not found. Please read the documentation.])
fi
+if test "x${USE_BUNDLED_APR}" != "x" ; then
+ apr_found=reconfig
+ apr_config=srclib/apr/apr-1-config
+fi
+
if test "$apr_found" = "reconfig"; then
APR_SUBDIR_CONFIG(srclib/apr,
- [$apache_apr_flags --prefix=$prefix --exec-prefix=$exec_prefix --libdir=$libdir --includedir=$includedir --bindir=$bindir --datadir=$datadir --with-installbuilddir=$installbuilddir],
+ [$apache_apr_flags --prefix=$prefix],
[--enable-layout=*|\'--enable-layout=*])
dnl We must be the first to build and the last to be cleaned
AP_BUILD_SRCLIB_DIRS="apr $AP_BUILD_SRCLIB_DIRS"
@@ -123,6 +128,11 @@
AC_MSG_ERROR([APR-util not found. Please read the documentation.])
fi
+if test "x${USE_BUNDLED_APR}" != "x" ; then
+ apu_found=reconfig
+ apu_config=srclib/apr-util/apu-1-config
+fi
+
# Catch some misconfigurations:
case ${apr_found}.${apu_found} in
reconfig.yes)
@@ -135,7 +145,7 @@
if test "$apu_found" = "reconfig"; then
APR_SUBDIR_CONFIG(srclib/apr-util,
- [--with-apr=../apr --prefix=$prefix --exec-prefix=$exec_prefix --libdir=$libdir --includedir=$includedir --bindir=$bindir],
+ [--with-apr=../apr --prefix=$prefix],
[--enable-layout=*|\'--enable-layout=*])
dnl We must be the last to build and the first to be cleaned
AP_BUILD_SRCLIB_DIRS="$AP_BUILD_SRCLIB_DIRS apr-util"
@@ -653,8 +663,14 @@
[Root directory of the Apache install area])
AC_DEFINE_UNQUOTED(SERVER_CONFIG_FILE, "${rel_sysconfdir}/${progname}.conf",
[Location of the config file, relative to the Apache root directory])
+AC_DEFINE_UNQUOTED(DEFAULT_ERRORLOG, "${rel_logfiledir}/httpd-error.log",
+ [Location of error log file])
+AC_DEFINE_UNQUOTED(DEFAULT_SCOREBOARD, "${rel_runtimedir}/apache_runtime_status",
+ [Location of ScoreBoard file])
AC_DEFINE_UNQUOTED(AP_TYPES_CONFIG_FILE, "${rel_sysconfdir}/mime.types",
[Location of the MIME types config file, relative to the Apache root directory])
+AC_DEFINE_UNQUOTED(DOCUMENT_LOCATION, "${rel_htdocsdir}",
+ [Location of document root])
AC_DEFINE_UNQUOTED(APACHE_MPM_DIR, "$MPM_DIR",
[Location of the source for the current MPM])