freebsd-ports/www/apache22/files/patch-support__Makefile.in
Philip M. Gollucci f3fd2dc043 - Fix the owner to be root:wheel on files* when running sudo make ...
This doesn't affect the package b/c pointyhat/tb run as root

PR:             ports/134456
With Hat:       apache@
2010-05-07 03:15:44 +00:00

24 lines
1 KiB
Text

--- ./support/Makefile.in.orig 2005-07-06 19:15:34.000000000 -0400
+++ ./support/Makefile.in 2010-05-06 19:37:54.258730387 -0400
@@ -16,17 +16,16 @@
@test -d $(DESTDIR)$(sbindir) || $(MKINSTALLDIRS) $(DESTDIR)$(sbindir)
@test -d $(DESTDIR)$(libexecdir) || $(MKINSTALLDIRS) $(DESTDIR)$(libexecdir)
@cp -p $(top_builddir)/server/httpd.exp $(DESTDIR)$(libexecdir)
- @for i in apxs apachectl dbmmanage; do \
+ @chown root:wheel $(DESTDIR)$(libexecdir)/httpd.exp
+ @for i in apxs apachectl dbmmanage split-logfile; do \
if test -f "$(builddir)/$$i"; then \
cp -p $$i $(DESTDIR)$(sbindir); \
chmod 755 $(DESTDIR)$(sbindir)/$$i; \
+ chown root:wheel $(DESTDIR)$(sbindir)/$$i; \
fi ; \
done
@if test -f "$(builddir)/envvars-std"; then \
- cp -p envvars-std $(DESTDIR)$(sbindir); \
- if test ! -f $(DESTDIR)$(sbindir)/envvars; then \
- cp -p envvars-std $(DESTDIR)$(sbindir)/envvars ; \
- fi ; \
+ cp -p envvars-std $(DESTDIR)$(sbindir)/envvars; \
fi
htpasswd_OBJECTS = htpasswd.lo