3e34029c2e
created by matherr() no longer need to do so.
52 lines
1.5 KiB
Text
52 lines
1.5 KiB
Text
--- configure.in.orig Sat Feb 28 15:58:12 1998
|
|
+++ configure.in Sat Feb 12 02:26:56 2005
|
|
@@ -303,6 +303,14 @@
|
|
a29k-*-*) # Default a29k environment.
|
|
use_collect2=yes
|
|
;;
|
|
+ alpha*-*-freebsd*)
|
|
+ tm_file=alpha/freebsd.h
|
|
+ if [[ "${OSVERSION}" -lt 600011 ]] ; \
|
|
+ then fixincludes=fixinc.math; \
|
|
+ else fixincludes=Makefile.in; \
|
|
+ fi
|
|
+ tmake_file=t-libc-ok
|
|
+ ;;
|
|
alpha*-*-linux-gnuecoff*)
|
|
tm_file="${tm_file} alpha/linux.h"
|
|
xm_file="${xm_file} alpha/xm-linux.h"
|
|
@@ -762,20 +770,24 @@
|
|
# Next line turned off because both 386BSD and BSD/386 use GNU ld.
|
|
# use_collect2=yes
|
|
;;
|
|
- i[[34567]]86-*-freebsdelf*)
|
|
- tm_file="i386/i386.h i386/att.h linux.h i386/freebsd-elf.h i386/perform.h"
|
|
- # On FreeBSD, the headers are already ok, except for math.h.
|
|
- fixincludes=fixinc.math
|
|
+ i[[34567]]86-*-freebsdaout*)
|
|
+ tm_file=i386/freebsd.h
|
|
+ if [[ "${OSVERSION}" -lt 600011 ]] ; \
|
|
+ then fixincludes=fixinc.math; \
|
|
+ else fixincludes=Makefile.in; \
|
|
+ fi
|
|
tmake_file=i386/t-freebsd
|
|
- gas=yes
|
|
- gnu_ld=yes
|
|
- stabs=yes
|
|
;;
|
|
i[[34567]]86-*-freebsd*)
|
|
- tm_file=i386/freebsd.h
|
|
- # On FreeBSD, the headers are already ok, except for math.h.
|
|
- fixincludes=fixinc.math
|
|
+ tm_file="i386/i386.h i386/att.h linux.h i386/freebsd.h i386/perform.h"
|
|
+ if [[ "${OSVERSION}" -lt 600011 ]] ; \
|
|
+ then fixincludes=fixinc.math; \
|
|
+ else fixincludes=Makefile.in; \
|
|
+ fi
|
|
tmake_file=i386/t-freebsd
|
|
+ gas=yes
|
|
+ gnu_ld=yes
|
|
+ stabs=yes
|
|
;;
|
|
i[[34567]]86-*-netbsd*)
|
|
tm_file=i386/netbsd.h
|