freebsd-ports/net/turses/files/patch-setup.py
Kubilay Kocak abcf4f690d net/turses: Update to 0.3.1
* Add future, add explicit versions to RUN_DEPENDS
 * Add configparser to a conditional RUN_DEPENDS ( < 3.x)
 * Remove TESTS option (test framework takes care of installing dependencies)
 * No longer restrict to 2.7 (Supports 3.x), add PKGNAMEPREFIX accordingly
 * Enable multiple concurrent Python installation (create unique file names)
 * Remove bits adding test command to setup.py patch
 * Switch to nose instead of pytest for tests
 * Update test target (to invoke nose directly) accordingly
 * Add NO_ARCH
2017-07-15 09:15:46 +00:00

25 lines
563 B
Python

--- setup.py.orig 2015-08-06 17:43:56 UTC
+++ setup.py
@@ -39,15 +39,17 @@ import turses
NAME = "turses"
REQUIREMENTS = [
- "urwid==1.3.0",
- "tweepy==3.3.0",
- "future==0.14.3",
+ "urwid>=1.3.0",
+ "tweepy>=3.3.0",
+ "future>=0.14.3",
]
if version_info[:2] == (2, 6):
REQUIREMENTS.append("argparse")
-TEST_REQUIREMENTS = list(REQUIREMENTS)
-TEST_REQUIREMENTS.extend(["mock", "pytest", "coverage", "tox"])
+TEST_REQUIREMENTS = [
+ "mock",
+ "nose"
+]
try:
long_description = open("README.rst").read() + "\n\n" + open(