8a8b31d05c
This port did not build with gcc 3.3.1. I also fixed a possible buffer overflow (they used gets() to read from stdin). Please review the patch file ``patch-cftypes.cpp'' with extra care, since I am not sure whether this makes sense (2 positions in the file, marked with ``TODO'' - thanks. Also added some lines in cftypes.cpp to overcome the absence of values.h on -current. PR: ports/55767 Submitted by: Simon Barner <barner@in.tum.de>
19 lines
628 B
Text
19 lines
628 B
Text
--- Makefile.orig Tue Aug 19 18:15:11 2003
|
|
+++ Makefile Tue Aug 19 18:33:06 2003
|
|
@@ -0,0 +1,16 @@
|
|
+NOPROFILE= true
|
|
+CXXFLAGS+= -Wno-deprecated
|
|
+LIB= cabinet
|
|
+LIBDIR= ${PREFIX}/lib
|
|
+INCSDIR= ${PREFIX}/include/cabinet
|
|
+INCDIR= ${INCSDIR} # for pre-bsd.incs.mk API
|
|
+SHLIB_MAJOR= 1
|
|
+SHLIB_MINOR= 0
|
|
+SRCS= bstring.cpp cfcreate.cpp cfdblock.cpp cffdrmgr.cpp cffile.cpp \
|
|
+ cffolder.cpp cfheader.cpp cfreader.cpp cftypes.cpp object.cpp
|
|
+INCS= bstring.h cfcreate.h cfdblock.h cffdrmgr.h cffile.h cffolder.h \
|
|
+ cfheader.h cfreader.h cftypes.h darray.h dos_comp.h object.hpp \
|
|
+ queue.hpp
|
|
+LDADD= -lz
|
|
+
|
|
+.include <bsd.lib.mk>
|