b2fd75e438
* kill devel/libtool and move to devel/libtool13, upgrading to 1.3.5 * upgrade repo-copied devel/libtool14 to 1.4.3 * break out libltdl into its own separate port * move to version-numbered binaries/scripts (ie: there is *no* 'libtool' any more -- USE_LIBTOOL and USE_LIBTOOL_VER are your friends) Approved by: portmgr (kris) - for the bsd.port.mk hooks Tested by: bento 4-exp builds (repeatedly)
50 lines
1.2 KiB
Text
50 lines
1.2 KiB
Text
|
|
$FreeBSD$
|
|
|
|
--- ltmain.sh.orig Mon Sep 10 22:33:26 2001
|
|
+++ ltmain.sh Wed Jan 23 16:39:22 2002
|
|
@@ -1062,6 +1062,12 @@
|
|
|
|
-module)
|
|
module=yes
|
|
+ case $host in
|
|
+ *-*-freebsd*)
|
|
+ # Do not build the useless static library
|
|
+ build_old_libs=no
|
|
+ ;;
|
|
+ esac
|
|
continue
|
|
;;
|
|
|
|
@@ -2444,6 +2450,9 @@
|
|
*-*-openbsd*)
|
|
# Do not include libc due to us having libc/libc_r.
|
|
;;
|
|
+ *-*-freebsd*)
|
|
+ # FreeBSD doesn't need this...
|
|
+ ;;
|
|
*)
|
|
# Add libc to deplibs on all other systems if necessary.
|
|
if test $build_libtool_need_lc = "yes"; then
|
|
@@ -4210,10 +4219,17 @@
|
|
fi
|
|
|
|
# Install the pseudo-library for information purposes.
|
|
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
|
|
- instname="$dir/$name"i
|
|
- $show "$install_prog $instname $destdir/$name"
|
|
- $run eval "$install_prog $instname $destdir/$name" || exit $?
|
|
+ case $host in
|
|
+ *-*-freebsd*)
|
|
+ # Do not install the useless pseudo-library
|
|
+ ;;
|
|
+ *)
|
|
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
|
|
+ instname="$dir/$name"i
|
|
+ $show "$install_prog $instname $destdir/$name"
|
|
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
|
|
+ ;;
|
|
+ esac
|
|
|
|
# Maybe install the static library, too.
|
|
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
|