2a3f43cb6b
This port was originally created by Pedro Giffuni. He offered me to take over it. I updated it to 3.1.0, added many options, etc. The option FCMIX is broken upstream, so it is not present in the port. Approved by: adamw (mentor) Differential Revision: https://reviews.freebsd.org/D13647
21 lines
644 B
Text
21 lines
644 B
Text
--- src/cvode/CMakeLists.txt.orig 2017-11-07 23:47:57 UTC
|
|
+++ src/cvode/CMakeLists.txt
|
|
@@ -114,6 +114,18 @@ IF(BUILD_SHARED_LIBS)
|
|
TARGET_LINK_LIBRARIES(sundials_cvode_shared m)
|
|
ENDIF()
|
|
|
|
+ IF(UNIX)
|
|
+ TARGET_LINK_LIBRARIES(sundials_cvode_shared m)
|
|
+ ENDIF()
|
|
+
|
|
+ IF(LAPACK_FOUND)
|
|
+ TARGET_LINK_LIBRARIES(sundials_cvode_shared ${LAPACK_LIBRARIES})
|
|
+ ENDIF()
|
|
+
|
|
+ IF(KLU_FOUND)
|
|
+ TARGET_LINK_LIBRARIES(sundials_cvode_shared ${KLU_LIBRARIES})
|
|
+ ENDIF ()
|
|
+
|
|
# Set the library name and make sure it is not deleted
|
|
SET_TARGET_PROPERTIES(sundials_cvode_shared
|
|
PROPERTIES OUTPUT_NAME sundials_cvode CLEAN_DIRECT_OUTPUT 1)
|