freebsd-ports/math/scilab/files/patch-xdg-open
Max Brazhnikov 57a37508d6 math/scilab:
- Update to 5.5.0
- Populate USES with desktop-file-utils, iconv, libtool, pathfix,
  and shared-mime-info
- Add dependency on xdg-utils
- Remove needless USE_LDCONFIG
- Clean up CONFIGURE_ENV from stale stuff
- Update options:
  . remove DOCS, FFTW, MATIO, UMFPACK (always build with them for simplicity)
  . remove NLS (doesn't build without it)
  . merge HELP with GUI
  . PVM is not supported anymore
  . Enable OCAML and TK by default
- Use options heplers
- Clean up post-patch section from stale fixes
- Convert to static pkg-plist
2014-09-04 18:20:53 +00:00

28 lines
1.7 KiB
Text

--- ./modules/gui/src/java/org/scilab/modules/gui/utils/WebBrowser.java.orig 2014-07-24 22:44:04.242274707 +0000
+++ ./modules/gui/src/java/org/scilab/modules/gui/utils/WebBrowser.java 2014-07-24 22:50:25.305278583 +0000
@@ -98,14 +98,14 @@
// We have <pierre.marechal@scilab.org>
String mail = "mailto:" + url.substring(1, url.length() - 1);
if (webprefs.defaultMailer) {
- Desktop.getDesktop().mail(new URI(mail));
+ Runtime.getRuntime().exec("xdg-email " + new URI(mail).toString());
} else {
Runtime.getRuntime().exec(webprefs.cmdMailer + " " + new URI(mail).toString());
}
}
} else if (protocol.equals("mailto")) {
if (webprefs.defaultMailer) {
- Desktop.getDesktop().mail(new URI(url));
+ Runtime.getRuntime().exec("xdg-open " + new URI(url).toString());
} else {
Runtime.getRuntime().exec(webprefs.cmdMailer + " " + new URI(url).toString());
}
@@ -113,7 +113,7 @@
if (webprefs.defaultBrowser) {
// Under Windows, ShellExecute is called with the URI and under Linux it is gnome_url_show.
// So to handle different protocol in URI, user must config its OS to handle them.
- Desktop.getDesktop().browse(new URI(url));
+ Runtime.getRuntime().exec("xdg-open " + new URI(url).toString());
} else {
Runtime.getRuntime().exec(webprefs.cmdBrowser + " " + new URI(url).toString());
}