31ae1852c8
PR: 214708 Submitted by: matthew@reztek.cz
147 lines
5.5 KiB
Text
147 lines
5.5 KiB
Text
# Install the EGL demos
|
|
#
|
|
--- src/egl/opengl/Makefile.in.orig 2015-12-09 21:24:01 UTC
|
|
+++ src/egl/opengl/Makefile.in
|
|
@@ -115,7 +115,7 @@ PRE_UNINSTALL = :
|
|
POST_UNINSTALL = :
|
|
build_triplet = @build@
|
|
host_triplet = @host@
|
|
-@HAVE_EGL_TRUE@noinst_PROGRAMS = eglinfo$(EXEEXT) peglgears$(EXEEXT) \
|
|
+@HAVE_EGL_TRUE@bin_PROGRAMS = eglinfo$(EXEEXT) peglgears$(EXEEXT) \
|
|
@HAVE_EGL_TRUE@ $(am__EXEEXT_1) $(am__EXEEXT_2)
|
|
subdir = src/egl/opengl
|
|
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
|
|
@@ -133,7 +133,8 @@ CONFIG_CLEAN_VPATH_FILES =
|
|
@HAVE_X11_TRUE@am__EXEEXT_2 = eglgears_x11$(EXEEXT) \
|
|
@HAVE_X11_TRUE@ egltri_x11$(EXEEXT) xeglgears$(EXEEXT) \
|
|
@HAVE_X11_TRUE@ xeglthreads$(EXEEXT)
|
|
-PROGRAMS = $(noinst_PROGRAMS)
|
|
+am__installdirs = "$(DESTDIR)$(bindir)"
|
|
+PROGRAMS = $(bin_PROGRAMS)
|
|
am_eglgears_x11_OBJECTS = eglgears.$(OBJEXT)
|
|
eglgears_x11_OBJECTS = $(am_eglgears_x11_OBJECTS)
|
|
eglgears_x11_DEPENDENCIES = ../eglut/libeglut_x11.la
|
|
@@ -389,7 +390,6 @@ pdfdir = @pdfdir@
|
|
prefix = @prefix@
|
|
program_transform_name = @program_transform_name@
|
|
psdir = @psdir@
|
|
-runstatedir = @runstatedir@
|
|
sbindir = @sbindir@
|
|
sharedstatedir = @sharedstatedir@
|
|
srcdir = @srcdir@
|
|
@@ -461,9 +461,49 @@ $(top_srcdir)/configure: $(am__configur
|
|
$(ACLOCAL_M4): $(am__aclocal_m4_deps)
|
|
cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
|
|
$(am__aclocal_m4_deps):
|
|
+install-binPROGRAMS: $(bin_PROGRAMS)
|
|
+ @$(NORMAL_INSTALL)
|
|
+ @list='$(bin_PROGRAMS)'; test -n "$(bindir)" || list=; \
|
|
+ if test -n "$$list"; then \
|
|
+ echo " $(MKDIR_P) '$(DESTDIR)$(bindir)'"; \
|
|
+ $(MKDIR_P) "$(DESTDIR)$(bindir)" || exit 1; \
|
|
+ fi; \
|
|
+ for p in $$list; do echo "$$p $$p"; done | \
|
|
+ sed 's/$(EXEEXT)$$//' | \
|
|
+ while read p p1; do if test -f $$p \
|
|
+ || test -f $$p1 \
|
|
+ ; then echo "$$p"; echo "$$p"; else :; fi; \
|
|
+ done | \
|
|
+ sed -e 'p;s,.*/,,;n;h' \
|
|
+ -e 's|.*|.|' \
|
|
+ -e 'p;x;s,.*/,,;s/$(EXEEXT)$$//;$(transform);s/$$/$(EXEEXT)/' | \
|
|
+ sed 'N;N;N;s,\n, ,g' | \
|
|
+ $(AWK) 'BEGIN { files["."] = ""; dirs["."] = 1 } \
|
|
+ { d=$$3; if (dirs[d] != 1) { print "d", d; dirs[d] = 1 } \
|
|
+ if ($$2 == $$4) files[d] = files[d] " " $$1; \
|
|
+ else { print "f", $$3 "/" $$4, $$1; } } \
|
|
+ END { for (d in files) print "f", d, files[d] }' | \
|
|
+ while read type dir files; do \
|
|
+ if test "$$dir" = .; then dir=; else dir=/$$dir; fi; \
|
|
+ test -z "$$files" || { \
|
|
+ echo " $(INSTALL_PROGRAM_ENV) $(LIBTOOL) $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=install $(INSTALL_PROGRAM) $$files '$(DESTDIR)$(bindir)$$dir'"; \
|
|
+ $(INSTALL_PROGRAM_ENV) $(LIBTOOL) $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=install $(INSTALL_PROGRAM) $$files "$(DESTDIR)$(bindir)$$dir" || exit $$?; \
|
|
+ } \
|
|
+ ; done
|
|
|
|
-clean-noinstPROGRAMS:
|
|
- @list='$(noinst_PROGRAMS)'; test -n "$$list" || exit 0; \
|
|
+uninstall-binPROGRAMS:
|
|
+ @$(NORMAL_UNINSTALL)
|
|
+ @list='$(bin_PROGRAMS)'; test -n "$(bindir)" || list=; \
|
|
+ files=`for p in $$list; do echo "$$p"; done | \
|
|
+ sed -e 'h;s,^.*/,,;s/$(EXEEXT)$$//;$(transform)' \
|
|
+ -e 's/$$/$(EXEEXT)/' \
|
|
+ `; \
|
|
+ test -n "$$list" || exit 0; \
|
|
+ echo " ( cd '$(DESTDIR)$(bindir)' && rm -f" $$files ")"; \
|
|
+ cd "$(DESTDIR)$(bindir)" && rm -f $$files
|
|
+
|
|
+clean-binPROGRAMS:
|
|
+ @list='$(bin_PROGRAMS)'; test -n "$$list" || exit 0; \
|
|
echo " rm -f" $$list; \
|
|
rm -f $$list || exit $$?; \
|
|
test -n "$(EXEEXT)" || exit 0; \
|
|
@@ -640,6 +680,9 @@ check-am: all-am
|
|
check: check-am
|
|
all-am: Makefile $(PROGRAMS)
|
|
installdirs:
|
|
+ for dir in "$(DESTDIR)$(bindir)"; do \
|
|
+ test -z "$$dir" || $(MKDIR_P) "$$dir"; \
|
|
+ done
|
|
install: install-am
|
|
install-exec: install-exec-am
|
|
install-data: install-data-am
|
|
@@ -672,8 +715,7 @@ maintainer-clean-generic:
|
|
@echo "it deletes files that may require special tools to rebuild."
|
|
clean: clean-am
|
|
|
|
-clean-am: clean-generic clean-libtool clean-noinstPROGRAMS \
|
|
- mostlyclean-am
|
|
+clean-am: clean-binPROGRAMS clean-generic clean-libtool mostlyclean-am
|
|
|
|
distclean: distclean-am
|
|
-rm -rf ./$(DEPDIR)
|
|
@@ -699,7 +741,7 @@ install-dvi: install-dvi-am
|
|
|
|
install-dvi-am:
|
|
|
|
-install-exec-am:
|
|
+install-exec-am: install-binPROGRAMS
|
|
|
|
install-html: install-html-am
|
|
|
|
@@ -739,23 +781,23 @@ ps: ps-am
|
|
|
|
ps-am:
|
|
|
|
-uninstall-am:
|
|
+uninstall-am: uninstall-binPROGRAMS
|
|
|
|
.MAKE: install-am install-strip
|
|
|
|
-.PHONY: CTAGS GTAGS TAGS all all-am check check-am clean clean-generic \
|
|
- clean-libtool clean-noinstPROGRAMS cscopelist-am ctags \
|
|
- ctags-am distclean distclean-compile distclean-generic \
|
|
+.PHONY: CTAGS GTAGS TAGS all all-am check check-am clean \
|
|
+ clean-binPROGRAMS clean-generic clean-libtool cscopelist-am \
|
|
+ ctags ctags-am distclean distclean-compile distclean-generic \
|
|
distclean-libtool distclean-tags distdir dvi dvi-am html \
|
|
- html-am info info-am install install-am install-data \
|
|
- install-data-am install-dvi install-dvi-am install-exec \
|
|
- install-exec-am install-html install-html-am install-info \
|
|
- install-info-am install-man install-pdf install-pdf-am \
|
|
- install-ps install-ps-am install-strip installcheck \
|
|
- installcheck-am installdirs maintainer-clean \
|
|
+ html-am info info-am install install-am install-binPROGRAMS \
|
|
+ install-data install-data-am install-dvi install-dvi-am \
|
|
+ install-exec install-exec-am install-html install-html-am \
|
|
+ install-info install-info-am install-man install-pdf \
|
|
+ install-pdf-am install-ps install-ps-am install-strip \
|
|
+ installcheck installcheck-am installdirs maintainer-clean \
|
|
maintainer-clean-generic mostlyclean mostlyclean-compile \
|
|
mostlyclean-generic mostlyclean-libtool pdf pdf-am ps ps-am \
|
|
- tags tags-am uninstall uninstall-am
|
|
+ tags tags-am uninstall uninstall-am uninstall-binPROGRAMS
|
|
|
|
.PRECIOUS: Makefile
|
|
|