freebsd-ports/devel/ocaml-findlib/files/patch-src__bytes__Makefile
2017-01-14 15:56:29 +00:00

15 lines
750 B
Text

--- src/bytes/Makefile.orig 2016-11-18 13:04:46 UTC
+++ src/bytes/Makefile
@@ -19,9 +19,9 @@ opt:
$(OCAMLBUILD) $$files
install: all
- mkdir -p "$(prefix)$(OCAML_SITELIB)/bytes"
- cd _build/ && cp ../META $(BYTE_FILES) "$(prefix)$(OCAML_SITELIB)/bytes"
- cd _build/ && for f in $(NATIVE_FILES) $(NATIVE_FILES_DYNLINK); do if [ -f "$$f" ]; then cp $$f "$(prefix)$(OCAML_SITELIB)/bytes"; fi; done
+ mkdir -p "$(DESTDIR)$(prefix)$(OCAML_SITELIB)/bytes"
+ cd _build/ && cp ../META $(BYTE_FILES) "$(DESTDIR)$(prefix)$(OCAML_SITELIB)/bytes"
+ cd _build/ && for f in $(NATIVE_FILES) $(NATIVE_FILES_DYNLINK); do if [ -f "$$f" ]; then cp $$f "$(DESTDIR)$(prefix)$(OCAML_SITELIB)/bytes"; fi; done
uninstall:
rm -rf "$(prefix)$(OCAML_SITELIB)/bytes"