freebsd-ports/dns/powerdns-recursor/files/patch-makefile
Bartek Rutkowski 6099aec1d2 dns/powerdns-recursor: update 3.5.3 -> 3.6.0
- Update to 3.6.0
- Mainteiner's timeout

PR:		191226
Submitted by:	Ralf van der Enden <tremere@cainites.net>
Reviewed by:	marino (mentor)
Approved by:	swills (mentor)
2014-07-21 18:36:04 +00:00

38 lines
1.2 KiB
Text

--- ./Makefile.orig 2014-06-20 11:24:09.000000000 +0200
+++ ./Makefile 2014-06-20 13:59:23.858179424 +0200
@@ -50,10 +50,10 @@
ifeq ($(STATIC),semi)
STATICFLAGS=-Wl,-Bstatic -lstdc++ $(LUALIBS) -lgcc -Wl,-Bdynamic -static-libgcc -lm -lc
LINKCC=$(CC)
- LDFLAGS += -ldl -lm
+ LDFLAGS += -lm
else
ifeq ($(STATIC),full)
- STATICFLAGS=-lstdc++ $(LUALIBS) -ldl -lm -static
+ STATICFLAGS=-lstdc++ $(LUALIBS) -lm -static
LINKCC=$(CC)
else
LDFLAGS += $(LUALIBS)
@@ -101,20 +101,18 @@
fi
install: build-stamp
- -mkdir -p $(DESTDIR)/$(SBINDIR)
mv pdns_recursor $(DESTDIR)/$(SBINDIR)
ifeq ($(STRIP_BINARIES), 1)
strip $(DESTDIR)/$(SBINDIR)/pdns_recursor
endif
- mkdir -p $(DESTDIR)/$(BINDIR)
mv rec_control $(DESTDIR)/$(BINDIR)
ifeq ($(STRIP_BINARIES), 1)
strip $(DESTDIR)/$(BINDIR)/rec_control
endif
-mkdir -p $(DESTDIR)/$(SYSCONFDIR)
$(DESTDIR)/$(SBINDIR)/pdns_recursor --config > $(DESTDIR)/$(SYSCONFDIR)/recursor.conf-dist
- -mkdir -p $(DESTDIR)/usr/share/man/man1
- cp pdns_recursor.1 rec_control.1 $(DESTDIR)/usr/share/man/man1
+ cp pdns_recursor.1 pdns_recursor.8
+ cp rec_control.1 rec_control.8
$(OS_SPECIFIC_INSTALL)
clean: binclean