freebsd-ports/editors/openoffice-3/files/patch-product+settings+settings.mk
Martin Blapp 6f36732a2d Make openoffice compile with gcc from ports, or just with CC=$CC and
CXX=$CXX, like it should normally be. Usable options are:

USEPORTGCC295=YES, USEPORTGCC31=YES and USEPORTGCC32=YES

Add a lot off gcc3.x fixes, make included stlport compile with CURRENT.

Next step will be to include a mozilla build, so we can link openoffice
against mozilla librarys without c++ compat problems.
2002-05-29 13:58:09 +00:00

26 lines
388 B
Makefile

--- ../product/settings/settings.mk.orig Wed May 29 00:16:16 2002
+++ ../product/settings/settings.mk Wed May 29 00:18:00 2002
@@ -83,9 +83,8 @@
OS=SOLARIS
PS=/
-CC=CC
-LINK=CC
-LIB=CC
+LINK=$(CC)
+LIB=$(CC)
ECHO=@echo
MKDIR=mkdir -p
CAT=cat
@@ -136,9 +135,8 @@
OS=LINUX
PLATFORM=linux
PS=/
-CC=gcc
-LINK=gcc
-LIB=gcc
+LINK=$(CC)
+LIB=$(CC)
ECHO=@echo
MKDIR=mkdir -p
CAT=cat