freebsd-ports/dns/odsclient/files/patch-Makefile
Emanuel Haupt 6a2076f011 - Support staging
- Respect CC
- Respect CFLAGS
- Fix build with clang
2014-02-19 12:19:30 +00:00

15 lines
372 B
Text

--- ./Makefile.orig 2014-02-19 13:17:44.470074950 +0100
+++ ./Makefile 2014-02-19 13:18:23.437075941 +0100
@@ -1,10 +1,9 @@
-CC=gcc -Wall
-CFLAGS=-O2
+CC?=gcc
DNSLIB=#-lresolv
OBJS=client.o memmem.o vasprintf.o socket.o
odsclient: $(OBJS)
- $(CC) -o odsclient $(OBJS) $(DNSLIB)
+ $(CC) $(CFLAGS) -o odsclient $(OBJS) $(DNSLIB)
clean:
rm -rf $(OBJS) odsclient *~