30c1a0a792
- update firefox 14.0.1 - update thunderbird to 14.0 - update seamonkey to 2.11 - switch to new options framework - add experimental rendering via cairo-qt (QT4 option) - add audio backend options (ALSA and PulseAudio) - rename SMB option to GNOMEVFS2 - turn on LOGGING by default (like upstream linux builds) - improve about:memory output - unbreak PGO - use system libs [1] - switch to libevent2 [2] - fix conflict with devel/libunwind and base gcc [3] - unbreak clang/libc++ build [4] - unbreak build with base gcc on >= 9.x [5] - use common IPC code with other BSDs[6] - and *miscellaneous improvements* PR: ports/146231 [1], ports/161421 [2] ports/150631, ports/168369, ports/168637, ports/168793, ports/168978 [3] ports/163454, ports/164905, ports/169231 [4] ports/169389, ports/169479 [5] Obtained from: pkgsrc via bugzilla #753046 [6] In collaboration with: Jan Beich (who did the major part of this work and deserves a special thank you!)
11 lines
322 B
Text
11 lines
322 B
Text
--- lib/freebl/Makefile~
|
|
+++ lib/freebl/Makefile
|
|
@@ -201,7 +201,7 @@ ifeq ($(USE_N32),1)
|
|
endif
|
|
endif
|
|
|
|
-ifeq ($(OS_TARGET),Linux)
|
|
+ifeq (,$(filter-out Linux FreeBSD, $(OS_TARGET)))
|
|
ifeq ($(CPU_ARCH),x86_64)
|
|
ASFILES = arcfour-amd64-gas.s mpi_amd64_gas.s
|
|
ASFLAGS += -march=opteron -m64 -fPIC -Wa,--noexecstack
|