freebsd-ports/sysutils/radmind/files/patch-largefile.h
Thomas Zander 79c08ab7c5 - Update to new revision 2014052201
- Stagify
- Add LICENSE*
- Remove IGNORE_TIMESTAMPS option
- Handle file ownerships via pkg-plist macros
- Silence superfluous warnings
- Handle stripping of installed binaries
- Pet portlint

PR:		190120
Submitted by:	mikeg@bsd-box.net (maintainer)
Reviewed by:	riggs
Approved by:	mentors (implicit), maintainer (timeout)
2014-07-12 09:31:02 +00:00

18 lines
599 B
C

--- ./largefile.h.orig 2010-12-13 04:42:49.000000000 +0100
+++ ./largefile.h 2014-06-29 12:15:04.246544121 +0200
@@ -18,3 +18,15 @@
#define strtoofft(x,y,z) (strtol((x),(y),(z)))
#define PRIofft "l"
#endif
+
+#if SIZEOF_TIME_T == 8
+ #ifdef HAVE_STRTOLL
+ #define strtotimet(x,y,z) (strtoll((x),(y),(z)))
+ #else /* !HAVE_STRTOLL */
+ #define strtotimet(x,y,z) (strtol((x),(y),(z)))
+ #endif /* HAVE_STRTOLL */
+ #define PRItimet "ll"
+#else /* SIZEOF_TIME_T != 8 */
+ #define strtotimet(x,y,z) (strtol((x),(y),(z)))
+ #define PRItimet "l"
+#endif /* SIZEOF_TIME_T */