freebsd-ports/databases/postgresql84-server/files/extra-patch-icu4
Martin Matuska 5382cf6af4 Fix build with ICU4 option after ICU 4.4 update
PR:		ports/148837
Approved by:	maintainer (timeout)
2010-08-05 21:37:28 +00:00

30 lines
1.2 KiB
Text

--- configure.in.orig 2010-03-25 22:25:10.655197193 +0100
+++ configure.in 2010-03-25 22:25:13.611658318 +0100
@@ -945,15 +945,19 @@
fi
if test "$with_icu" = yes ; then
- AC_CHECK_LIB(icui18n, ucol_open_3_8, [], [
- AC_CHECK_LIB(icui18n, ucol_open_3_6, [], [
- AC_CHECK_LIB(icui18n, ucol_open_3_4, [], [AC_MSG_ERROR([library 'icui18n' is required for ICU])])
- ])
+ AC_CHECK_LIB(icui18n, ucol_open_44, [], [
+ AC_CHECK_LIB(icui18n, ucol_open_3_8, [], [
+ AC_CHECK_LIB(icui18n, ucol_open_3_6, [], [
+ AC_CHECK_LIB(icui18n, ucol_open_3_4, [], [AC_MSG_ERROR([library 'icui18n' is required for ICU])])
+ ])
+ ])
])
- AC_CHECK_LIB(icuuc, ucnv_fromUChars_3_8, [], [
- AC_CHECK_LIB(icuuc, ucnv_fromUChars_3_6, [], [
- AC_CHECK_LIB(icuuc, ucnv_fromUChars_3_4, [], [AC_MSG_ERROR([library 'icuuc' is required for ICU])])
- ])
+ AC_CHECK_LIB(icuuc, ucnv_fromUChars_44, [], [
+ AC_CHECK_LIB(icuuc, ucnv_fromUChars_3_8, [], [
+ AC_CHECK_LIB(icuuc, ucnv_fromUChars_3_6, [], [
+ AC_CHECK_LIB(icuuc, ucnv_fromUChars_3_4, [], [AC_MSG_ERROR([library 'icuuc' is required for ICU])])
+ ])
+ ])
])
fi