d57e3ecdf7
cc1plus: error: unrecognized command line option "-msse" cc1plus: error: unrecognized command line option "-msse2" cc1plus: error: unrecognized command line option "-std=gnu++0x" The previous patchfile is now split into two, depending on whether ARCH is x86 or not. Since REINPLACE is now deprecated for this purpose, I could not figure out any other way to do it. Approved by: portmgr (tier-2 blanket)
11 lines
383 B
Makefile
11 lines
383 B
Makefile
--- dpf/Makefile.base.mk.orig 2019-12-11 09:25:25 UTC
|
|
+++ dpf/Makefile.base.mk
|
|
@@ -106,7 +106,7 @@ endif
|
|
# Set build and link flags
|
|
|
|
BASE_FLAGS = -Wall -Wextra -pipe -MD -MP
|
|
-BASE_OPTS = -O3 -ffast-math -mtune=generic -msse -msse2 -fdata-sections -ffunction-sections
|
|
+BASE_OPTS = -O3 -ffast-math -fdata-sections -ffunction-sections
|
|
|
|
ifeq ($(MACOS),true)
|
|
# MacOS linker flags
|