4168d77f03
Xen 4.7.1 contains the following XSAs: 184, 185, 186, 187, 188 and 190 which where missing in the previous package. Additionally XSAs 191, 192, 193, 194, 195, 197 and 198 are also applied. Approved by: bapt Sponsored by: Citrix Systems R&D
66 lines
2.5 KiB
Diff
66 lines
2.5 KiB
Diff
From 4000a7c7d7b0e01837abd3918e393f289c07d68c Mon Sep 17 00:00:00 2001
|
|
From: Roger Pau Monne <roger.pau@citrix.com>
|
|
Date: Tue, 25 Oct 2016 11:53:28 +0200
|
|
Subject: [PATCH] tools/configure: fix pkg-config install path for FreeBSD
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
pkg-config from FreeBSD ports doesn't have ${prefix}/share/pkgconfig in the
|
|
default search path, fix this by having a PKG_INSTALLDIR variable that can
|
|
be changed on a per-OS basis.
|
|
|
|
It would be best to use PKG_INSTALLDIR as defined by the pkg.m4 macro, but
|
|
sadly this also reports a wrong value on FreeBSD (${libdir}/pkgconfig, which
|
|
expands to /usr/local/lib/pkgconfig by default, and is also _not_ part of
|
|
the default pkg-config search path).
|
|
|
|
This patch should not change the behavior for Linux installs.
|
|
|
|
Signed-off-by: Roger Pau Monné <roger.pau@citrix.com>
|
|
Reported-by: Alexander Nusov <alexander.nusov@nfvexpress.com>
|
|
Acked-by: Wei Liu <wei.liu2@citrix.com>
|
|
Release-acked-by: Wei Liu <wei.liu2@citrix.com>
|
|
---
|
|
config/FreeBSD.mk | 1 +
|
|
config/Paths.mk.in | 2 ++
|
|
tools/libxl/Makefile | 4 ++--
|
|
3 files changed, 5 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/config/FreeBSD.mk b/config/FreeBSD.mk
|
|
index bb3a5d0..afeaefb 100644
|
|
--- a/config/FreeBSD.mk
|
|
+++ b/config/FreeBSD.mk
|
|
@@ -2,3 +2,4 @@ include $(XEN_ROOT)/config/StdGNU.mk
|
|
|
|
# No wget on FreeBSD base system
|
|
WGET = ftp
|
|
+PKG_INSTALLDIR = ${prefix}/libdata/pkgconfig
|
|
diff --git a/config/Paths.mk.in b/config/Paths.mk.in
|
|
index 62cea48..a603295 100644
|
|
--- a/config/Paths.mk.in
|
|
+++ b/config/Paths.mk.in
|
|
@@ -56,3 +56,5 @@ XENFIRMWAREDIR := @XENFIRMWAREDIR@
|
|
|
|
XEN_CONFIG_DIR := @XEN_CONFIG_DIR@
|
|
XEN_SCRIPT_DIR := @XEN_SCRIPT_DIR@
|
|
+
|
|
+PKG_INSTALLDIR := ${SHAREDIR}/pkgconfig
|
|
diff --git a/tools/libxl/Makefile b/tools/libxl/Makefile
|
|
index 79e4019..af0a3ad 100644
|
|
--- a/tools/libxl/Makefile
|
|
+++ b/tools/libxl/Makefile
|
|
@@ -320,8 +320,8 @@ install: all
|
|
$(INSTALL_DATA) libxlutil.a $(DESTDIR)$(libdir)
|
|
$(INSTALL_DATA) libxl.h libxl_event.h libxl_json.h _libxl_types.h _libxl_types_json.h _libxl_list.h libxl_utils.h libxl_uuid.h libxlutil.h $(DESTDIR)$(includedir)
|
|
$(INSTALL_DATA) bash-completion $(DESTDIR)$(BASH_COMPLETION_DIR)/xl.sh
|
|
- $(INSTALL_DATA) xenlight.pc $(DESTDIR)$(SHAREDIR)/pkgconfig/
|
|
- $(INSTALL_DATA) xlutil.pc $(DESTDIR)$(SHAREDIR)/pkgconfig/
|
|
+ $(INSTALL_DATA) xenlight.pc $(DESTDIR)$(PKG_INSTALLDIR)
|
|
+ $(INSTALL_DATA) xlutil.pc $(DESTDIR)$(PKG_INSTALLDIR)
|
|
|
|
.PHONY: clean
|
|
clean:
|
|
--
|
|
2.9.3 (Apple Git-75)
|
|
|