7cd341218d
versions. Use BSD's bsd.lib.mk to build uclmmbase and avoid building (most of the) functionality, that is present in our base libraries (btree, md5, etc.) In vic stop using PERL, use Tcl/Tk-8.4, respect CC and CFLAGS and some other improvements. vic is thus unbroken on 5.x Per fenner's (much) earlier e-mail, grab maintainership for the time being. PR: ports/75066 (obsoleted) Approved by: fenner (implicitly)
19 lines
480 B
C++
19 lines
480 B
C++
--- Tcl.cpp Thu Sep 9 08:21:53 1999
|
|
+++ Tcl.cpp Thu Sep 23 18:59:59 2004
|
|
@@ -66,6 +66,7 @@
|
|
{
|
|
instance_.tcl_ = tcl;
|
|
instance_.application_ = application;
|
|
+ Tcl_Init(tcl);
|
|
}
|
|
|
|
void Tcl::evalc(const char* s)
|
|
@@ -214,7 +215,7 @@
|
|
}
|
|
}
|
|
|
|
-int TclObject::callback(ClientData cd, Tcl_Interp*, int ac, char** av)
|
|
+int TclObject::callback(ClientData cd, Tcl_Interp*, int ac, const char** av)
|
|
{
|
|
TclObject* tc = (TclObject*)cd;
|
|
return (tc->command(ac, (const char*const*)av));
|