3cc71f11dc
- Fix the inner Makefile.BSD to allow -jX builds, remove MAKE_JOBS_UNSAFE Reported by: pkg-fallout
33 lines
903 B
Text
33 lines
903 B
Text
--- ./Makefile.BSD.orig 2009-09-24 22:16:17.000000000 +0200
|
|
+++ ./Makefile.BSD 2013-05-05 23:13:58.797891197 +0200
|
|
@@ -97,7 +97,7 @@
|
|
${SV_DIR}/pcre/get.o \
|
|
${SV_DIR}/pcre/pcre.o
|
|
|
|
-.if ${USE_ASM} == ${ASM}
|
|
+.if defined(ASM) && ${USE_ASM} == ${ASM}
|
|
SV_ASM_OBJS = \
|
|
${SV_DIR}/bothtoolsa.o \
|
|
${SV_DIR}/math.o
|
|
@@ -119,7 +119,7 @@
|
|
${QWDTOOLS_DIR}/sync.o \
|
|
${QWDTOOLS_DIR}/tools.o
|
|
|
|
-.if ${USE_ASM} == ${ASM}
|
|
+.if defined(ASM) && ${USE_ASM} == ${ASM}
|
|
QWDTOOLS_ASM_OBJS = \
|
|
${SV_DIR}/bothtoolsa.o
|
|
.endif
|
|
@@ -129,10 +129,10 @@
|
|
#############################################################################
|
|
|
|
.c.o:
|
|
- ${CC} ${DO_CFLAGS} -c $< -o $*.o
|
|
+ ${CC} ${DO_CFLAGS} -c $< -o $@
|
|
|
|
.s.o:
|
|
- ${CC} ${DO_CFLAGS} -DELF -x assembler-with-cpp -c $< -o $*.o
|
|
+ ${CC} ${DO_CFLAGS} -DELF -x assembler-with-cpp -c $< -o $@
|
|
|
|
all: mvdsv qwdtools
|
|
${STRIP} ${STRIP_FLAGS} mvdsv qwdtools
|