freebsd-ports/devel/cdecl/files/patch-Makefile
2013-10-12 20:29:58 +00:00

36 lines
1 KiB
Text

--- ./Makefile.orig 1996-01-16 06:36:38.000000000 +0100
+++ ./Makefile 2013-06-10 00:05:02.101069622 +0200
@@ -15,13 +15,13 @@
#
# add -DUSE_READLINE To compile in support for the GNU readline library.
-CFLAGS= -s -O2 -DUSE_READLINE
-CC= gcc
+CFLAGS+= -s -DUSE_READLINE
+CC?= gcc
LIBS= -lreadline -ltermcap
ALLFILES= makefile cdgram.y cdlex.l cdecl.c cdecl.1 testset testset++
-BINDIR= /usr/bin
-MANDIR= /usr/man/man1
-CATDIR= /usr/man/cat1
+BINDIR= $(PREFIX)/bin
+MANDIR= $(PREFIX)/man/man1
+CATDIR= $(PREFIX)/man/cat1
INSTALL= install -c
INSTALL_DATA= install -c -m 644
@@ -43,10 +43,10 @@
./c++decl < testset++
install: cdecl
- $(INSTALL) cdecl $(BINDIR)
+ ${BSD_INSTALL_PROGRAM} cdecl $(STAGEDIR)$(BINDIR)
- ln $(BINDIR)/cdecl $(BINDIR)/c++decl
+ ln -s $(BINDIR)/cdecl $(STAGEDIR)$(BINDIR)/c++decl
- $(INSTALL_DATA) cdecl.1 $(MANDIR)
- $(INSTALL_DATA) c++decl.1 $(MANDIR)
+ ${BSD_INSTALL_MAN} cdecl.1 $(STAGEDIR)$(MANDIR)
+ ln -s $(MANDIR)/cdecl.1 $(STAGEDIR)$(MANDIR)/c++decl.1
clean:
rm -f cdgram.c cdlex.c cdecl y.output c++decl