The following maintenance operations were performed: - Recreate all patches with `make makepatch` - Add LICENSE - Update MAINTAINER to kami@freebsd.org - games/ioquake3 - Replace a lot of `.if ${PORT_OPTIONS:MFOO}` with `bsd.options.mk` fu - Add support for slaves using different SDL versions - games/ioquake3-devel - Update to GIT revision 2808 - Use SDL2 - games/iourbanterror - Change treatment of patches so `make makepatch` doesn't screw the patches in ${MASTERDIR}/files over - Update 4.2.018 to 4.2.023 - games/urbanterror-data - Update 4.2.018 to 4.2.023 - Fix install without DOCS Reviewed by: cs Approved by: cs Differential Revision: https://reviews.freebsd.org/D5816
18 lines
731 B
C
18 lines
731 B
C
--- code/qcommon/files.c.orig 2009-02-26 13:02:59 UTC
|
|
+++ code/qcommon/files.c
|
|
@@ -241,6 +241,7 @@ static cvar_t *fs_apppath;
|
|
#endif
|
|
|
|
static cvar_t *fs_basepath;
|
|
+static cvar_t *fs_libpath;
|
|
static cvar_t *fs_basegame;
|
|
static cvar_t *fs_gamedirvar;
|
|
static searchpath_t *fs_searchpaths;
|
|
@@ -2761,6 +2762,7 @@ static void FS_Startup( const char *game
|
|
fs_debug = Cvar_Get( "fs_debug", "0", 0 );
|
|
fs_basepath = Cvar_Get ("fs_basepath", Sys_DefaultInstallPath(), CVAR_INIT );
|
|
fs_basegame = Cvar_Get ("fs_basegame", "", CVAR_INIT );
|
|
+ fs_libpath = Cvar_Get ("fs_libpath", Sys_DefaultLibPath(), CVAR_INIT );
|
|
homePath = Sys_DefaultHomePath();
|
|
if (!homePath || !homePath[0]) {
|
|
homePath = fs_basepath->string;
|