freebsd-ports/databases/redis-devel/files/patch-deps-linenoise-Makefile
Sergey A. Osokin dae4751ead Upgrade from 3.0.0-rc1 to 3.0.0-rc2.
<ChangeLog>

--[ Redis 3.0.0 RC2 (version 2.9.102) ] Release date: 13 jan 2014

Upgrade urgency: LOW.

This is the second release candidate of Redis Cluster. The major changes
are back porting of things implemented into the unstable branch while
this was still possible (with the new development model adopted only
bug fixes will be merged in the future).

RC2 also fixes a few Redis Cluster non critical bugs.

>> General changes

* [FIX] A number of minor bug fixes.

* [NEW] Diskless replication backportede.
* [NEW] Lua bitops and updated cmsgpack backported.
* [NEW] Transparent Huge Pages warnings and reporting backported.

>> Cluster changes

* [FIX] Fix PUBLISH cluster bus message count field.
* [FIX] It is no longer possible to write outside node hash slots using Lua.
* [FIX] Valgrind warnings (no actual bugs).
* [FIX] Less strict in acceptiong myself->ip if it's not populated.

* [NEW] Better testing of Lua scripts.

>> Sentinel changes

No changes to Sentinel.

</ChangeLog>
2015-01-17 19:23:18 +00:00

15 lines
342 B
Text

--- deps/linenoise/Makefile.orig 2015-01-17 22:13:25.000000000 +0300
+++ deps/linenoise/Makefile 2015-01-17 22:13:45.000000000 +0300
@@ -1,10 +1,10 @@
STD=
WARN= -Wall
-OPT= -Os
+#OPT= -Os
R_CFLAGS= $(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS)
R_LDFLAGS= $(LDFLAGS)
-DEBUG= -g
+#DEBUG= -g
R_CC=$(CC) $(R_CFLAGS)
R_LD=$(CC) $(R_LDFLAGS)