Merge all changes from databases/redis-devel to databases/redis. <ChangeLog> Redis 3.0 release notes ======================= --[ Redis 3.0.0 ] Release date: 1 Apr 2015 >> What's new in Redis 3.0 compared to Redis 2.8? * Redis Cluster: a distributed implementation of a subset of Redis. * New "embedded string" object encoding resulting in less cache misses. Big speed gain under certain work loads. * AOF child -> parent final data transmission to minimize latency due to "last write" during AOF rewrites. * Much improved LRU approximation algorithm for keys eviction. * WAIT command to block waiting for a write to be transmitted to the specified number of slaves. * MIGRATE connection caching. Much faster keys migraitons. * MIGARTE new options COPY and REPLACE. * CLIENT PAUSE command: stop processing client requests for a specified amount of time. * BITCOUNT performance improvements. * CONFIG SET accepts memory values in different units (for example you can use "CONFIG SET maxmemory 1gb"). * Redis log format slightly changed reporting in each line the role of the instance (master/slave) or if it's a saving child log. * INCR performance improvements. >> Refactoring changes (no new features nor bug fixes) * Blocking operations full refactoring (blocked.c) * Client output buffer memory tracking refactored. </ChangeLog>
39 lines
935 B
Text
39 lines
935 B
Text
--- src/Makefile.orig 2015-04-01 17:01:44.000000000 +0300
|
|
+++ src/Makefile 2015-04-07 21:30:22.464962000 +0300
|
|
@@ -22,7 +22,7 @@
|
|
WARN=-Wall -W
|
|
OPT=$(OPTIMIZATION)
|
|
|
|
-PREFIX?=/usr/local
|
|
+PREFIX:=$(PREFIX)
|
|
INSTALL_BIN=$(PREFIX)/bin
|
|
INSTALL=install
|
|
|
|
@@ -52,7 +52,6 @@
|
|
FINAL_CFLAGS=$(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS) $(REDIS_CFLAGS)
|
|
FINAL_LDFLAGS=$(LDFLAGS) $(REDIS_LDFLAGS) $(DEBUG)
|
|
FINAL_LIBS=-lm
|
|
-DEBUG=-g -ggdb
|
|
|
|
ifeq ($(uname_S),SunOS)
|
|
# SunOS
|
|
@@ -63,6 +62,11 @@
|
|
ifeq ($(uname_S),Darwin)
|
|
# Darwin (nothing to do)
|
|
else
|
|
+ifeq ($(uname_S),FreeBSD)
|
|
+ # FreeBSD
|
|
+ FINAL_CFLAGS?= $(CFLAGS) $(REDIS_CFLAGS) -I${PREFIX}/include
|
|
+ FINAL_LDFLAGS= $(LDFLAGS) -pthread
|
|
+else
|
|
ifeq ($(uname_S),AIX)
|
|
# AIX
|
|
FINAL_LDFLAGS+= -Wl,-bexpall
|
|
@@ -75,6 +79,7 @@
|
|
endif
|
|
endif
|
|
endif
|
|
+endif
|
|
# Include paths to dependencies
|
|
FINAL_CFLAGS+= -I../deps/hiredis -I../deps/linenoise -I../deps/lua/src
|
|
|