freebsd-ports/graphics/igt-gpu-tools/files/patch-tools_meson.build
Jake Freeland 5d303ab480
graphics/igt-gpu-tools: Test suite for drm drivers
The igt testing suite is separated into tests and tools that target kms,
memory management, and command submission.  These tests are especially
helpful for low-level reporting, transparent tracking of kernel changes,
and efficient debugging of modern drm drivers.

Reviewed by:	diizzy, lwhsu, jrm
Differential Revision:	https://reviews.freebsd.org/D36213
2022-09-09 12:06:45 -03:00

24 lines
797 B
Text

--- tools/meson.build.orig 2022-08-31 20:00:01 UTC
+++ tools/meson.build
@@ -89,10 +89,10 @@ install_subdir('registers', install_dir : datadir)
install_subdir('registers', install_dir : datadir)
-executable('intel_gpu_top', 'intel_gpu_top.c',
- install : true,
- install_rpath : bindir_rpathdir,
- dependencies : [lib_igt_perf,lib_igt_device_scan,lib_igt_drm_fdinfo,math])
+#executable('intel_gpu_top', 'intel_gpu_top.c',
+# install : true,
+# install_rpath : bindir_rpathdir,
+# dependencies : [lib_igt_perf,lib_igt_device_scan,lib_igt_drm_fdinfo,math])
executable('amd_hdmi_compliance', 'amd_hdmi_compliance.c',
dependencies : [tool_deps],
@@ -111,5 +111,5 @@ endif
install : true)
endif
-subdir('i915-perf')
+#subdir('i915-perf')
subdir('null_state_gen')