freebsd-ports/emulators/tpm-emulator/files/patch-tpmd-unix-CMakeLists.txt
Hiroki Sato 5c2173b0df security/trousers:
- Update to 0.3.13.
- Remove CONFLICTS with emulators/tpm-emulator.

  Two separate binaries, sbin/tcsd (for actual TPM device) and
  sbin/tcsd_emu (for TPM emulator) are now installed.  rc.d/tcsd chooses
  one of them depending on $tcsd_mode.  When tcsd_mode="native" (default)
  it runs sbin/tcsd, and when tcsd_mode="emulator" it runs sbin/tcsd_emu.
  Note that sbin/tcsd_emu depends on tpmd in emulators/tpm-emulator.

- Simplify @sample.

emulators/tpm-emulator:

- Remove CONFLICTS with security/trousers.
- Simplify rc.d/tpmd.
2016-05-18 13:53:45 +00:00

13 lines
389 B
Text

--- tpmd/unix/CMakeLists.txt.orig 2011-12-20 18:30:06 UTC
+++ tpmd/unix/CMakeLists.txt
@@ -10,8 +10,8 @@ add_executable(tpmd ${tpmd_SRCS})
if(MTM_EMULATOR)
add_definitions(-DMTM_EMULATOR)
target_link_libraries(tpmd mtm tpm tpm_crypto)
-else()
+else(MTM_EMULATOR)
target_link_libraries(tpmd tpm tpm_crypto)
-endif()
+endif(MTM_EMULATOR)
install(TARGETS tpmd RUNTIME DESTINATION bin)