8425077e7e
- Unbreak it by fixing the library search path, remove the DEPRECATED and EXPIRATION_DATE too. PR: ports/83998 Submitted by: Stephane Legrand <stephane@freebsd.org> (maintainer)
17 lines
786 B
Text
17 lines
786 B
Text
--- src/Makefile.orig Sun Jul 24 14:40:44 2005
|
|
+++ src/Makefile Sun Jul 24 14:41:16 2005
|
|
@@ -22,12 +22,12 @@
|
|
CFLAGS += -Wall -pedantic -fPIC
|
|
GTK_24 := $(shell pkg-config --atleast-version=2.4 'gtk+-2.0' && echo yes)
|
|
|
|
-TCL_VERSION := $(shell echo 'puts $$tcl_version' | tclsh)
|
|
+TCL_VERSION := 84
|
|
|
|
# this breaks build on GTK 2.4
|
|
# -DGTK_DISABLE_DEPRECATED -DGNOME_DISABLE_DEPRECATED
|
|
export ADDCFLAGS := -DVERSION=\"$(VERSION)\" -DUSE_TCL_STUBS $(shell pkg-config --cflags gtk+-2.0)
|
|
-export LIBS := $(shell pkg-config --libs gtk+-2.0) -ltclstub$(TCL_VERSION)
|
|
+export LIBS := $(shell pkg-config --libs gtk+-2.0) -ltclstub$(TCL_VERSION) -L$(LOCALBASE)/lib
|
|
|
|
############################################################
|
|
# There should be no need to edit something below this line
|