freebsd-ports/lang/erlang/files/patch-erts-emulator-Makefile.in
Jimmy Olgeni f9269d328d * Use gcc(1) rather than ld(1) to link the crypto_drv.so port driver, else the Erlang runtime would fail to load it.
* Use the correct struct member when compiling SCTP support (this should unbreak CURRENT).

Submitted by:	dumbbell
2007-07-02 20:47:53 +00:00

15 lines
254 B
Text

$FreeBSD$
--- erts/emulator/Makefile.in.orig
+++ erts/emulator/Makefile.in
@@ -265,7 +265,9 @@
endif
WITH_SCTP=@WITH_SCTP@
ifdef WITH_SCTP
+ifneq ($(findstring freebsd,$(TARGET)),freebsd)
LIBS += -lsctp
+endif
endif
ORG_THR_LIBS=@EMU_THR_LIBS@