freebsd-ports/graphics/waffle/files/patch-examples_CMakeLists.txt
Koop Mast 32579890bf Update waffle to 1.5.1.
Use USES=compiler:c11 to allow it to build on older FreeBSD versions.
Enable GLX support.
Fix plist when cmake is in debug build mode.

Submitted by:	dumbbell@
2015-02-22 20:21:48 +00:00

11 lines
419 B
Text

--- examples/CMakeLists.txt.orig 2015-01-22 20:00:17 UTC
+++ examples/CMakeLists.txt
@@ -11,7 +11,7 @@ install(
# Target: simple-x11-egl (executable)
# ----------------------------------------------------------------------------
-if(waffle_on_linux)
+if(waffle_on_linux OR waffle_on_freebsd)
add_executable(simple-x11-egl simple-x11-egl.c)
target_link_libraries(simple-x11-egl ${waffle_libname})
endif()