freebsd-ports/games/f1spirit-remake/files/patch-sources-Makefile
Martin Wilke 3cb8ed77a3 The F-1 Spirit remake is mostly identical to the original Konami
classic F-1 Spirit game in that you first have to clear tracks in
a top-down view with stock cars, rally cars and so on by accumulating
points given for finishing in the first places until you actually
get to play the Formula 1 tracks.

Otherwise there are quite some enhancements, namely improved graphics,
improved music, more realistic physics, real shape shown in the
maps, camera rotation and zoom, split screen for up to four players,
(online) highscore tables and replay saving.

WWW: http://www.braingames.getput.com/f1spirit/default.asp

PR:		ports/123686
Submitted by:	Dmitry Marakasov <amdmi3 at amdmi3.ru>
2008-05-18 00:02:03 +00:00

16 lines
631 B
Text

--- sources/Makefile.orig 2005-11-03 09:49:06.000000000 +0300
+++ sources/Makefile 2008-05-15 00:16:20.000000000 +0400
@@ -19,11 +19,11 @@
all: f1s
%.o: %.cpp
- c++ -c -g3 -O3 $< -o $@ `sdl-config --cflags` -I/usr/local/include/SDL
+ ${CXX} ${CXXFLAGS} -c $< -o $@ `${SDL_CONFIG} --cflags`
# dynamically linked binary:
f1s: $(OBJS)
- c++ $^ -o $@ `sdl-config --libs` `curl-config --libs` -lSDL_net -lSDL_image -lSDL_mixer -lSDL_sound -lSDL_sound -lGL -lGLU -I/usr/local/include/SDL
+ ${CXX} $^ -o $@ `${SDL_CONFIG} --libs` `curl-config --libs` -lSDL_net -lSDL_image -lSDL_mixer -lSDL_sound -lGL -lGLU
clean:
rm -f f1s