freebsd-ports/games/masterserver/files/patch-common.mk
Alejandro Pulver 6e618a2f7b LASANGE aims at creating a mostly-automated LAN session administration and
management system. It will provide game server management (instant deployment
of game servers) and tournament management in a more advanced and automated
way than other systems. It will also consist of basic tools for LAN sessions
such as a generic modular Masterserver, IRC bot, etc.

WWW: http://lasange-system.sourceforge.net/
2007-01-25 22:29:06 +00:00

38 lines
896 B
Makefile

--- ./common.mk.orig Tue Mar 15 15:35:46 2005
+++ ./common.mk Thu Jan 25 11:36:02 2007
@@ -1,18 +1,18 @@
SHELL = /bin/sh
-prefix = /usr
+prefix = $(PREFIX)
bindir = $(prefix)/bin
sbindir = $(prefix)/sbin
libdir = $(prefix)/lib
-INSTALL = /usr/bin/install
-INSTALLDATA = /usr/bin/install -m 644
-CC = gcc
-LD = ld
-RM = rm -f
-RMDIR = rmdir -p --ignore-fail-on-non-empty
+INSTALL ?= /usr/bin/install
+INSTALLDATA = $(BSD_INSTALL_DATA)
+CC ?= gcc
+LD ?= ld
+RM ?= rm -f
+RMDIR = -rmdir -p
-CFLAGS = -DDEBUG -g -Wall
+CFLAGS += -DDEBUG -g -Wall
PLATFORM := $(shell uname)
ifeq "$(PLATFORM)" "Linux"
@@ -26,7 +26,7 @@
ifeq "$(PLATFORM)" "FreeBSD"
CFLAGS_MAIN = $(CFLAGS) -rdynamic \
- -DMASTERSERVER_LIB_DIR=\"/usr/lib/lasange/masterserver\"
+ -DMASTERSERVER_LIB_DIR=\"$(libdir)/masterserver\"
CFLAGS_PLUGIN = $(CFLAGS) -fPIC
CFLAGS_TESTS = $(CFLAGS) -lm
LDFLAGS = -pthread