freebsd-ports/sysutils/cfengine3/files/patch-af
Ying-Chieh Liao a26a168208 This patch fixes the following problems:
* cfengine deadlocking in the resolver due to being linked against libc_r
    * cfd issuing 'ioctl:  No such network device' whenever it is invoked.

change maintainer email
add more docs
Patches obtained from Michael Kyle <mike@rainc.com>

PR:		29649
Submitted by:	MAINTAINER
2001-08-17 14:20:09 +00:00

13 lines
374 B
Text

Fix the linking so only cfd is linked with pthreads. This keeps cfengine
from trying to use thread-unsafe resolver functions.
--- src/Makefile.am.orig Fri Aug 10 23:58:47 2001
+++ src/Makefile.am Fri Aug 10 23:59:07 2001
@@ -95,6 +95,7 @@
patches.c
cfd_LDADD = -L../pub -lpub $(LEXLIB)
+cfd_LDFLAGS = -pthread $(LDFLAGS)
cfrun_SOURCES = \
cfrun.c \