freebsd-ports/security/py-rsa/files/patch-setup.py
Kubilay Kocak 5133b75bd7 security/py-rsa: Update to 3.3 (Fixes CVE-2016-1494)
- Update PORTVERSION and distinfo checksum (3.3)
- Modernize TEST entries (test target, TEST_DEPENDS, et al)
- Update setup.py patch (zip_safe no longer needed)
- Add LICENSE_FILE
- Enable NO_ARCH

This version fixed a security vulnerability:

https://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2016-1494

PR:		206746
Reported by:	Sevan Janiyan <venture37 geeklan co.uk>
Security:	e78bfc9d-cb1e-11e5-b251-0050562a4d7b
Security:	CVE-2016-1494
MFH:		2016Q1
2016-02-04 10:39:48 +00:00

12 lines
358 B
Python

--- setup.py.orig 2016-01-13 08:43:51 UTC
+++ setup.py
@@ -42,6 +42,9 @@ setup(name='rsa',
install_requires=[
'pyasn1 >= 0.1.3',
],
+ tests_require=[
+ 'unittest2',
+ ],
entry_points={'console_scripts': [
'pyrsa-priv2pub = rsa.util:private_to_public',
'pyrsa-keygen = rsa.cli:keygen',