freebsd-ports/lang/io-devel/files/extra-patch-CMakeLists.txt
Pietro Cerutti 9059621629 lang/io, lang/io-devel: fix build on !x86
While at it, add test target to io-devel.

PR:		246225
Submitted by:	pkubaj
2020-05-26 09:15:55 +00:00

11 lines
415 B
Text

--- CMakeLists.txt.orig 2018-08-07 11:40:49 UTC
+++ CMakeLists.txt
@@ -41,7 +41,7 @@ IF(CMAKE_COMPILER_IS_GNUCC OR (CMAKE_C_C
SET(CMAKE_BUILD_TYPE_DebugFast)
SET(CMAKE_CXX_FLAGS_DEBUGFAST "-g -O0")
SET(CMAKE_C_FLAGS_DEBUGFAST "-g -O0")
- SET(CMAKE_C_FLAGS "-msse2")
+ SET(CMAKE_C_FLAGS "-D__SIMD_NO_SIMD__")
if(NOT CMAKE_BUILD_TYPE)
SET(CMAKE_BUILD_TYPE "DebugFast")
endif(NOT CMAKE_BUILD_TYPE)