freebsd-ports/x11-clocks/wmfishtime/files/patch-Makefile
FUJISHIMA Satsuki cfbbad11c9 get rid of libgnugetopt dependency for -CURRENT,
use USE_GETOPT_LONG instead.
use getopt_long() instead of getopt_long_only().
2003-07-14 02:37:35 +00:00

28 lines
820 B
Text

--- Makefile.orig Sun May 27 05:49:41 2001
+++ Makefile Sun Jul 6 20:29:07 2003
@@ -6,23 +6,21 @@
# no user serviceable parts below this line
# optimization cflags
-CFLAGS = -O3 -Wall `gtk-config --cflags` ${EXTRA}
# profiling cflags
# CFLAGS=-ansi -pedantic -Wall -pg -O3 `gtk-config --cflags` ${EXTRA} -DPRO
# test coverage cflags
# CFLAGS=-fprofile-arcs -ftest-coverage -Wall -ansi -pedantic -g `gtk-config --cflags` ${EXTRA} -DPRO
-CC = gcc
SHELL = sh
OBJS = fishmon.o
-LIBS = `gtk-config --libs | sed "s/-lgtk//g"`
+LIBS = `echo $(GTK_LIBS) | sed "s/-lgtk12//g"`
INSTALL = -m 755
all: wmfishtime
wmfishtime: $(OBJS)
- $(CC) $(CFLAGS) -o wmfishtime $(OBJS) $(LIBS)
+ $(CC) $(CFLAGS) -o wmfishtime $(OBJS) $(LIBS) $(LDFLAGS)
clean:
rm -rf wmfishtime *.o *.bb* *.gcov gmon.* *.da *~ .xvpics