freebsd-ports/security/pecl-crypto/files/patch-config.m4
Jason Unovitch c862bdb809 security/pecl-crypto: update 0.1.1 -> 0.2.1
- Update PORTVERSION and distinfo for the new release (0.2.1)
- USES: tar:tgz instead of EXTRACT_SUFX
- Regenerate patch while here (portlint)

Changes:
| 0.2.1
* Fixed C89 compatibility issue in Base64
| 0.2.0
* Support for PHP 7
* Added Crypto stream BIO wrapper
* Improved error handling
* Added an integer overflow checking
* Removed Algorithm class and AlogirithmException class
* Introduced a MAC class as a subclass of Hash and parent of HMAC and CMAC
* Added MACException class subclassing HashException
* Fixed HMAC and CMAC implementation and added key param to constructor
* Fixed and tested CCM mode
* Added new error code for failed tag verification (TAG_VERIFY_FAILED)
* Add setTagLength Cipher method replacing length param in getTag
* Removed Rand::egd
* Created a complete API documentation

PR:		204668
Submitted by:	Gasol Wu <gasol.wu@gmail.com> (maintainer)
2015-11-20 03:55:34 +00:00

11 lines
418 B
Text

--- config.m4.orig 2015-11-15 21:36:25 UTC
+++ config.m4
@@ -17,6 +17,8 @@ if test "$PHP_CRYPTO" != "no"; then
PHP_ADD_INCLUDE($OPENSSL_INCDIR)
CRYPTO_LIBS=`$PKG_CONFIG --libs openssl`
PHP_EVAL_LIBLINE($CRYPTO_LIBS, CRYPTO_SHARED_LIBADD)
+ else
+ PHP_EVAL_LIBLINE("-lssl -lcrypto", CRYPTO_SHARED_LIBADD)
fi
AC_DEFINE(HAVE_CRYPTOLIB,1,[Enable objective OpenSSL Crypto wrapper])