freebsd-ports/graphics/jbigkit/files/patch-ab
Mikhail Teterin 930ee8b15e Attempt to make it easier to use non-default compiler.
Submitted by:	DROOPY (partially)
2011-03-13 23:49:20 +00:00

40 lines
1.1 KiB
Text

--- libjbig/Makefile Fri Apr 10 20:33:27 1998
+++ libjbig/Makefile Wed Sep 16 11:57:16 1998
@@ -5,9 +5,11 @@
-CC = gcc
# Options for the compiler: A high optimization level is suggested
-CFLAGS = -O -Wall -ansi -pedantic
+CFLAGS += -Wall -ansi -pedantic
-all: libjbig.a tstcodec
+JBIGLIB=libjbig.a
+SOJBIGLIB=libjbig.so.1
+
+all: libjbig.a $(SOJBIGLIB)
tstcodec: tstcodec.c jbig.c jbig.h jbig_tab.o
$(CC) $(CFLAGS) -o tstcodec -DTEST_CODEC tstcodec.c jbig.c \
@@ -18,10 +25,21 @@
ar rc libjbig.a jbig.o jbig_tab.o
ranlib libjbig.a
+$(SOJBIGLIB): jbig.so jbig_tab.so
+ rm -f ${.TARGET}
+ $(CC) -o ${.TARGET} ${LDFLAGS} -shared -Wl,-soname,${.TARGET} ${.ALLSRC}
+ ln -sf ${.TARGET} `echo ${.TARGET} | sed 's/\.so.*$$/.so/'`
+
jbig.o: jbig.c jbig.h
+.SUFFIXES: .c .so
+.c.so:
+ ${CC} -c -fpic -DPIC ${CFLAGS} ${.IMPSRC} -o ${.TARGET}
+jbig.so: jbig.c jbig.h
+jbig_tab.so: jbig_tab.c
+
test: tstcodec
./tstcodec
clean:
- rm -f *.o *~ core gmon.out dbg_d\=??.pbm tstcodec
+ rm -f *.o *~ core gmon.out dbg_d\=??.pbm tstcodec *.so libjbig.so.1 libjbig.so.1.1 libjbig.a