freebsd-ports/sysutils/cdrkit/files/patch-wodim__CMakeLists.txt
Thomas Zander 79a9a4c52f Separate cdrkit into cdrkit and genisoimage
Previously, cdrkit conflicted with cdrtools and dvd+rw-tools.
The split allows for genisoimage to be installed without removing
cdrtools and dvd+rw-tools.

PR:		203828
Submitted by:	lifanov@mail.lifanov.com
Approved by:	maintainer timeout
2016-01-23 09:12:04 +00:00

19 lines
716 B
Text

--- wodim/CMakeLists.txt.orig 2009-11-27 22:57:01 UTC
+++ wodim/CMakeLists.txt
@@ -9,16 +9,6 @@ SET(CDRECORD_COMMON_SRCS cd_misc.c defau
INCLUDE(CheckIncludeFiles)
-#force libcap usage on Linux
-CHECK_INCLUDE_FILES("sys/capability.h" HAVE_SYS_CAPABILITY_H)
-IF(HAVE_SYS_CAPABILITY_H)
- LIST(APPEND EXTRA_LIBS cap)
-ELSE(HAVE_SYS_CAPABILITY_H)
- IF(CMAKE_SYSTEM_NAME MATCHES "Linux")
- MESSAGE(FATAL_ERROR "Error: found a Linux system but no libcap header. Install libcap-dev.")
- ENDIF(CMAKE_SYSTEM_NAME MATCHES "Linux")
-ENDIF(HAVE_SYS_CAPABILITY_H)
-
LINK_DIRECTORIES(../librols ../libusal ../libedc)
ADD_DEFINITIONS(-DHAVE_LIB_EDC_ECC -DCLONE_WRITE -DDRV_DVD -DFIFO -DAUINFO -DUSE_LARGEFILES )