- Update USES comment (Python 3.3 support dropped) - Rebase setup.py patch (idna change released) - Remove comment about failing tests due to httpbin issue which seems to now be fixed. This update includes a pinned urllib3 version bump to < 1.25, which paves the way for a net/urllib3 update to 1.24 [1]. Note: 2.20.0 includes a security vulnerability fix for CVE-2018-18074 Changelog: https://github.com/requests/requests/blob/v2.21.0/HISTORY.md PR: 229322 [1] Security: 50ad9a9a-1e28-11e9-98d7-0050562a4d7b MFH: 2019Q1
12 lines
288 B
Python
12 lines
288 B
Python
# pytest-cov and its dependencies are not compulsory
|
|
|
|
--- setup.py.orig 2019-01-22 02:52:54 UTC
|
|
+++ setup.py
|
|
@@ -50,7 +50,6 @@ requires = [
|
|
]
|
|
test_requirements = [
|
|
'pytest-httpbin==0.0.7',
|
|
- 'pytest-cov',
|
|
'pytest-mock',
|
|
'pytest-xdist',
|
|
'PySocks>=1.5.6, !=1.5.7',
|