92531c1b9e
at compile time. Its author suggests to use -D__LITTLE_ENDIAN__ in the program's Makefile and this is the solution proposed in ports/131878. Since FreeBSD (and FreeBSD ports) might be used on big-endian architectures as well as on little endian architectures I decided to instrument an already present endianness check directly in the affected source file instead. - Bump PORTREVISION since this affects the content (and functionality) of the port's binary package. Pr: 133159 Submitted by: Thomas-Martin Seck <tmseck@web.de> (maintainer)
581 lines
18 KiB
Text
581 lines
18 KiB
Text
This file contains various patches that in general try to enable the
|
|
compilation of the squid_kerb_auth authentication helper program on
|
|
all versions of FreeBSD that are currently supported by the FreeBSD
|
|
ports framework where Heimdal is part of the base system.
|
|
|
|
--- configure.orig 2009-02-05 19:27:06.000000000 +0100
|
|
+++ configure 2009-02-05 19:40:29.000000000 +0100
|
|
@@ -773,10 +773,13 @@
|
|
NTLM_AUTH_HELPERS
|
|
DIGEST_AUTH_HELPERS
|
|
NEGOTIATE_AUTH_HELPERS
|
|
-EXTERNAL_ACL_HELPERS
|
|
+KRB5CONFIG
|
|
+KERBLIBS
|
|
+KERBINC
|
|
CPP
|
|
GREP
|
|
EGREP
|
|
+EXTERNAL_ACL_HELPERS
|
|
LIBSASL
|
|
ENABLE_UNLINKD_TRUE
|
|
ENABLE_UNLINKD_FALSE
|
|
@@ -5789,50 +5792,59 @@
|
|
fi
|
|
|
|
|
|
-# Check whether --enable-ntlm-fail-open was given.
|
|
-if test "${enable_ntlm_fail_open+set}" = set; then
|
|
- enableval=$enable_ntlm_fail_open; if test "$enableval" = "yes" ; then
|
|
-
|
|
-cat >>confdefs.h <<\_ACEOF
|
|
-#define NTLM_FAIL_OPEN 1
|
|
-_ACEOF
|
|
|
|
+if `echo "$NEGOTIATE_AUTH_HELPERS" | grep -q squid_kerb_auth`; then
|
|
+ # Extract the first word of "krb5-config", so it can be a program name with args.
|
|
+set dummy krb5-config; ac_word=$2
|
|
+{ $as_echo "$as_me:$LINENO: checking for $ac_word" >&5
|
|
+$as_echo_n "checking for $ac_word... " >&6; }
|
|
+if test "${ac_cv_path_KRB5CONFIG+set}" = set; then
|
|
+ $as_echo_n "(cached) " >&6
|
|
+else
|
|
+ case $KRB5CONFIG in
|
|
+ [\\/]* | ?:[\\/]*)
|
|
+ ac_cv_path_KRB5CONFIG="$KRB5CONFIG" # Let the user override the test with a path.
|
|
+ ;;
|
|
+ *)
|
|
+ as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
|
|
+for as_dir in $PATH
|
|
+do
|
|
+ IFS=$as_save_IFS
|
|
+ test -z "$as_dir" && as_dir=.
|
|
+ for ac_exec_ext in '' $ac_executable_extensions; do
|
|
+ if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_test_x "$as_dir/$ac_word$ac_exec_ext"; }; then
|
|
+ ac_cv_path_KRB5CONFIG="$as_dir/$ac_word$ac_exec_ext"
|
|
+ $as_echo "$as_me:$LINENO: found $as_dir/$ac_word$ac_exec_ext" >&5
|
|
+ break 2
|
|
fi
|
|
+done
|
|
+done
|
|
+IFS=$as_save_IFS
|
|
|
|
+ test -z "$ac_cv_path_KRB5CONFIG" && ac_cv_path_KRB5CONFIG="false"
|
|
+ ;;
|
|
+esac
|
|
fi
|
|
-
|
|
-
|
|
-EXTERNAL_ACL_HELPERS=
|
|
-# Check whether --enable-external-acl-helpers was given.
|
|
-if test "${enable_external_acl_helpers+set}" = set; then
|
|
- enableval=$enable_external_acl_helpers; case "$enableval" in
|
|
- yes)
|
|
- echo "ERROR: --enable-external-acl-helpers requires an argument"
|
|
- exit 1
|
|
- ;;
|
|
- no)
|
|
- ;;
|
|
- *)
|
|
- EXTERNAL_ACL_HELPERS="`echo $enableval| sed -e 's/,/ /g;s/ */ /g'`"
|
|
- esac
|
|
-
|
|
+KRB5CONFIG=$ac_cv_path_KRB5CONFIG
|
|
+if test -n "$KRB5CONFIG"; then
|
|
+ { $as_echo "$as_me:$LINENO: result: $KRB5CONFIG" >&5
|
|
+$as_echo "$KRB5CONFIG" >&6; }
|
|
+else
|
|
+ { $as_echo "$as_me:$LINENO: result: no" >&5
|
|
+$as_echo "no" >&6; }
|
|
fi
|
|
|
|
-if test -n "$EXTERNAL_ACL_HELPERS"; then
|
|
- for helper in $EXTERNAL_ACL_HELPERS; do
|
|
- if test -f $srcdir/helpers/external_acl/$helper/Makefile.in; then
|
|
- :
|
|
- else
|
|
- echo "ERROR: external acl helper $helper does not exists"
|
|
- exit 1
|
|
- fi
|
|
- done
|
|
- echo "External acl helpers built: $EXTERNAL_ACL_HELPERS"
|
|
-fi
|
|
|
|
+ if test -z "$KRB5CONFIG"; then
|
|
+ { { $as_echo "$as_me:$LINENO: error: sorry" >&5
|
|
+$as_echo "$as_me: error: sorry" >&2;}
|
|
+ { (exit need krb5-config to determine compilation settings); exit need krb5-config to determine compilation settings; }; }
|
|
+ else
|
|
+ KERBLIBS=`$KRB5CONFIG --libs gssapi`
|
|
+ KERBINC=`$KRB5CONFIG --cflags`
|
|
|
|
|
|
-if test "$require_sasl" = "yes"; then
|
|
+ fi
|
|
|
|
ac_ext=c
|
|
ac_cpp='$CPP $CPPFLAGS'
|
|
@@ -6454,6 +6466,359 @@
|
|
|
|
|
|
|
|
+for ac_header in gssapi/gssapi.h
|
|
+do
|
|
+as_ac_Header=`$as_echo "ac_cv_header_$ac_header" | $as_tr_sh`
|
|
+if { as_var=$as_ac_Header; eval "test \"\${$as_var+set}\" = set"; }; then
|
|
+ { $as_echo "$as_me:$LINENO: checking for $ac_header" >&5
|
|
+$as_echo_n "checking for $ac_header... " >&6; }
|
|
+if { as_var=$as_ac_Header; eval "test \"\${$as_var+set}\" = set"; }; then
|
|
+ $as_echo_n "(cached) " >&6
|
|
+fi
|
|
+ac_res=`eval 'as_val=${'$as_ac_Header'}
|
|
+ $as_echo "$as_val"'`
|
|
+ { $as_echo "$as_me:$LINENO: result: $ac_res" >&5
|
|
+$as_echo "$ac_res" >&6; }
|
|
+else
|
|
+ # Is the header compilable?
|
|
+{ $as_echo "$as_me:$LINENO: checking $ac_header usability" >&5
|
|
+$as_echo_n "checking $ac_header usability... " >&6; }
|
|
+cat >conftest.$ac_ext <<_ACEOF
|
|
+/* confdefs.h. */
|
|
+_ACEOF
|
|
+cat confdefs.h >>conftest.$ac_ext
|
|
+cat >>conftest.$ac_ext <<_ACEOF
|
|
+/* end confdefs.h. */
|
|
+$ac_includes_default
|
|
+#include <$ac_header>
|
|
+_ACEOF
|
|
+rm -f conftest.$ac_objext
|
|
+if { (ac_try="$ac_compile"
|
|
+case "(($ac_try" in
|
|
+ *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
|
|
+ *) ac_try_echo=$ac_try;;
|
|
+esac
|
|
+eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
|
|
+$as_echo "$ac_try_echo") >&5
|
|
+ (eval "$ac_compile") 2>conftest.er1
|
|
+ ac_status=$?
|
|
+ grep -v '^ *+' conftest.er1 >conftest.err
|
|
+ rm -f conftest.er1
|
|
+ cat conftest.err >&5
|
|
+ $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
+ (exit $ac_status); } && {
|
|
+ test -z "$ac_c_werror_flag" ||
|
|
+ test ! -s conftest.err
|
|
+ } && test -s conftest.$ac_objext; then
|
|
+ ac_header_compiler=yes
|
|
+else
|
|
+ $as_echo "$as_me: failed program was:" >&5
|
|
+sed 's/^/| /' conftest.$ac_ext >&5
|
|
+
|
|
+ ac_header_compiler=no
|
|
+fi
|
|
+
|
|
+rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
|
|
+{ $as_echo "$as_me:$LINENO: result: $ac_header_compiler" >&5
|
|
+$as_echo "$ac_header_compiler" >&6; }
|
|
+
|
|
+# Is the header present?
|
|
+{ $as_echo "$as_me:$LINENO: checking $ac_header presence" >&5
|
|
+$as_echo_n "checking $ac_header presence... " >&6; }
|
|
+cat >conftest.$ac_ext <<_ACEOF
|
|
+/* confdefs.h. */
|
|
+_ACEOF
|
|
+cat confdefs.h >>conftest.$ac_ext
|
|
+cat >>conftest.$ac_ext <<_ACEOF
|
|
+/* end confdefs.h. */
|
|
+#include <$ac_header>
|
|
+_ACEOF
|
|
+if { (ac_try="$ac_cpp conftest.$ac_ext"
|
|
+case "(($ac_try" in
|
|
+ *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
|
|
+ *) ac_try_echo=$ac_try;;
|
|
+esac
|
|
+eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
|
|
+$as_echo "$ac_try_echo") >&5
|
|
+ (eval "$ac_cpp conftest.$ac_ext") 2>conftest.er1
|
|
+ ac_status=$?
|
|
+ grep -v '^ *+' conftest.er1 >conftest.err
|
|
+ rm -f conftest.er1
|
|
+ cat conftest.err >&5
|
|
+ $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
+ (exit $ac_status); } >/dev/null && {
|
|
+ test -z "$ac_c_preproc_warn_flag$ac_c_werror_flag" ||
|
|
+ test ! -s conftest.err
|
|
+ }; then
|
|
+ ac_header_preproc=yes
|
|
+else
|
|
+ $as_echo "$as_me: failed program was:" >&5
|
|
+sed 's/^/| /' conftest.$ac_ext >&5
|
|
+
|
|
+ ac_header_preproc=no
|
|
+fi
|
|
+
|
|
+rm -f conftest.err conftest.$ac_ext
|
|
+{ $as_echo "$as_me:$LINENO: result: $ac_header_preproc" >&5
|
|
+$as_echo "$ac_header_preproc" >&6; }
|
|
+
|
|
+# So? What about this header?
|
|
+case $ac_header_compiler:$ac_header_preproc:$ac_c_preproc_warn_flag in
|
|
+ yes:no: )
|
|
+ { $as_echo "$as_me:$LINENO: WARNING: $ac_header: accepted by the compiler, rejected by the preprocessor!" >&5
|
|
+$as_echo "$as_me: WARNING: $ac_header: accepted by the compiler, rejected by the preprocessor!" >&2;}
|
|
+ { $as_echo "$as_me:$LINENO: WARNING: $ac_header: proceeding with the compiler's result" >&5
|
|
+$as_echo "$as_me: WARNING: $ac_header: proceeding with the compiler's result" >&2;}
|
|
+ ac_header_preproc=yes
|
|
+ ;;
|
|
+ no:yes:* )
|
|
+ { $as_echo "$as_me:$LINENO: WARNING: $ac_header: present but cannot be compiled" >&5
|
|
+$as_echo "$as_me: WARNING: $ac_header: present but cannot be compiled" >&2;}
|
|
+ { $as_echo "$as_me:$LINENO: WARNING: $ac_header: check for missing prerequisite headers?" >&5
|
|
+$as_echo "$as_me: WARNING: $ac_header: check for missing prerequisite headers?" >&2;}
|
|
+ { $as_echo "$as_me:$LINENO: WARNING: $ac_header: see the Autoconf documentation" >&5
|
|
+$as_echo "$as_me: WARNING: $ac_header: see the Autoconf documentation" >&2;}
|
|
+ { $as_echo "$as_me:$LINENO: WARNING: $ac_header: section \"Present But Cannot Be Compiled\"" >&5
|
|
+$as_echo "$as_me: WARNING: $ac_header: section \"Present But Cannot Be Compiled\"" >&2;}
|
|
+ { $as_echo "$as_me:$LINENO: WARNING: $ac_header: proceeding with the preprocessor's result" >&5
|
|
+$as_echo "$as_me: WARNING: $ac_header: proceeding with the preprocessor's result" >&2;}
|
|
+ { $as_echo "$as_me:$LINENO: WARNING: $ac_header: in the future, the compiler will take precedence" >&5
|
|
+$as_echo "$as_me: WARNING: $ac_header: in the future, the compiler will take precedence" >&2;}
|
|
+ ( cat <<\_ASBOX
|
|
+## ----------------------------------------------- ##
|
|
+## Report this to http://www.squid-cache.org/bugs/ ##
|
|
+## ----------------------------------------------- ##
|
|
+_ASBOX
|
|
+ ) | sed "s/^/$as_me: WARNING: /" >&2
|
|
+ ;;
|
|
+esac
|
|
+{ $as_echo "$as_me:$LINENO: checking for $ac_header" >&5
|
|
+$as_echo_n "checking for $ac_header... " >&6; }
|
|
+if { as_var=$as_ac_Header; eval "test \"\${$as_var+set}\" = set"; }; then
|
|
+ $as_echo_n "(cached) " >&6
|
|
+else
|
|
+ eval "$as_ac_Header=\$ac_header_preproc"
|
|
+fi
|
|
+ac_res=`eval 'as_val=${'$as_ac_Header'}
|
|
+ $as_echo "$as_val"'`
|
|
+ { $as_echo "$as_me:$LINENO: result: $ac_res" >&5
|
|
+$as_echo "$ac_res" >&6; }
|
|
+
|
|
+fi
|
|
+if test `eval 'as_val=${'$as_ac_Header'}
|
|
+ $as_echo "$as_val"'` = yes; then
|
|
+ cat >>confdefs.h <<_ACEOF
|
|
+#define `$as_echo "HAVE_$ac_header" | $as_tr_cpp` 1
|
|
+_ACEOF
|
|
+
|
|
+fi
|
|
+
|
|
+done
|
|
+
|
|
+ if test x"$ac_cv_header_gssapi_gssapi_h" != x"yes"; then
|
|
+
|
|
+for ac_header in gssapi.h
|
|
+do
|
|
+as_ac_Header=`$as_echo "ac_cv_header_$ac_header" | $as_tr_sh`
|
|
+if { as_var=$as_ac_Header; eval "test \"\${$as_var+set}\" = set"; }; then
|
|
+ { $as_echo "$as_me:$LINENO: checking for $ac_header" >&5
|
|
+$as_echo_n "checking for $ac_header... " >&6; }
|
|
+if { as_var=$as_ac_Header; eval "test \"\${$as_var+set}\" = set"; }; then
|
|
+ $as_echo_n "(cached) " >&6
|
|
+fi
|
|
+ac_res=`eval 'as_val=${'$as_ac_Header'}
|
|
+ $as_echo "$as_val"'`
|
|
+ { $as_echo "$as_me:$LINENO: result: $ac_res" >&5
|
|
+$as_echo "$ac_res" >&6; }
|
|
+else
|
|
+ # Is the header compilable?
|
|
+{ $as_echo "$as_me:$LINENO: checking $ac_header usability" >&5
|
|
+$as_echo_n "checking $ac_header usability... " >&6; }
|
|
+cat >conftest.$ac_ext <<_ACEOF
|
|
+/* confdefs.h. */
|
|
+_ACEOF
|
|
+cat confdefs.h >>conftest.$ac_ext
|
|
+cat >>conftest.$ac_ext <<_ACEOF
|
|
+/* end confdefs.h. */
|
|
+$ac_includes_default
|
|
+#include <$ac_header>
|
|
+_ACEOF
|
|
+rm -f conftest.$ac_objext
|
|
+if { (ac_try="$ac_compile"
|
|
+case "(($ac_try" in
|
|
+ *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
|
|
+ *) ac_try_echo=$ac_try;;
|
|
+esac
|
|
+eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
|
|
+$as_echo "$ac_try_echo") >&5
|
|
+ (eval "$ac_compile") 2>conftest.er1
|
|
+ ac_status=$?
|
|
+ grep -v '^ *+' conftest.er1 >conftest.err
|
|
+ rm -f conftest.er1
|
|
+ cat conftest.err >&5
|
|
+ $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
+ (exit $ac_status); } && {
|
|
+ test -z "$ac_c_werror_flag" ||
|
|
+ test ! -s conftest.err
|
|
+ } && test -s conftest.$ac_objext; then
|
|
+ ac_header_compiler=yes
|
|
+else
|
|
+ $as_echo "$as_me: failed program was:" >&5
|
|
+sed 's/^/| /' conftest.$ac_ext >&5
|
|
+
|
|
+ ac_header_compiler=no
|
|
+fi
|
|
+
|
|
+rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
|
|
+{ $as_echo "$as_me:$LINENO: result: $ac_header_compiler" >&5
|
|
+$as_echo "$ac_header_compiler" >&6; }
|
|
+
|
|
+# Is the header present?
|
|
+{ $as_echo "$as_me:$LINENO: checking $ac_header presence" >&5
|
|
+$as_echo_n "checking $ac_header presence... " >&6; }
|
|
+cat >conftest.$ac_ext <<_ACEOF
|
|
+/* confdefs.h. */
|
|
+_ACEOF
|
|
+cat confdefs.h >>conftest.$ac_ext
|
|
+cat >>conftest.$ac_ext <<_ACEOF
|
|
+/* end confdefs.h. */
|
|
+#include <$ac_header>
|
|
+_ACEOF
|
|
+if { (ac_try="$ac_cpp conftest.$ac_ext"
|
|
+case "(($ac_try" in
|
|
+ *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
|
|
+ *) ac_try_echo=$ac_try;;
|
|
+esac
|
|
+eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
|
|
+$as_echo "$ac_try_echo") >&5
|
|
+ (eval "$ac_cpp conftest.$ac_ext") 2>conftest.er1
|
|
+ ac_status=$?
|
|
+ grep -v '^ *+' conftest.er1 >conftest.err
|
|
+ rm -f conftest.er1
|
|
+ cat conftest.err >&5
|
|
+ $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
+ (exit $ac_status); } >/dev/null && {
|
|
+ test -z "$ac_c_preproc_warn_flag$ac_c_werror_flag" ||
|
|
+ test ! -s conftest.err
|
|
+ }; then
|
|
+ ac_header_preproc=yes
|
|
+else
|
|
+ $as_echo "$as_me: failed program was:" >&5
|
|
+sed 's/^/| /' conftest.$ac_ext >&5
|
|
+
|
|
+ ac_header_preproc=no
|
|
+fi
|
|
+
|
|
+rm -f conftest.err conftest.$ac_ext
|
|
+{ $as_echo "$as_me:$LINENO: result: $ac_header_preproc" >&5
|
|
+$as_echo "$ac_header_preproc" >&6; }
|
|
+
|
|
+# So? What about this header?
|
|
+case $ac_header_compiler:$ac_header_preproc:$ac_c_preproc_warn_flag in
|
|
+ yes:no: )
|
|
+ { $as_echo "$as_me:$LINENO: WARNING: $ac_header: accepted by the compiler, rejected by the preprocessor!" >&5
|
|
+$as_echo "$as_me: WARNING: $ac_header: accepted by the compiler, rejected by the preprocessor!" >&2;}
|
|
+ { $as_echo "$as_me:$LINENO: WARNING: $ac_header: proceeding with the compiler's result" >&5
|
|
+$as_echo "$as_me: WARNING: $ac_header: proceeding with the compiler's result" >&2;}
|
|
+ ac_header_preproc=yes
|
|
+ ;;
|
|
+ no:yes:* )
|
|
+ { $as_echo "$as_me:$LINENO: WARNING: $ac_header: present but cannot be compiled" >&5
|
|
+$as_echo "$as_me: WARNING: $ac_header: present but cannot be compiled" >&2;}
|
|
+ { $as_echo "$as_me:$LINENO: WARNING: $ac_header: check for missing prerequisite headers?" >&5
|
|
+$as_echo "$as_me: WARNING: $ac_header: check for missing prerequisite headers?" >&2;}
|
|
+ { $as_echo "$as_me:$LINENO: WARNING: $ac_header: see the Autoconf documentation" >&5
|
|
+$as_echo "$as_me: WARNING: $ac_header: see the Autoconf documentation" >&2;}
|
|
+ { $as_echo "$as_me:$LINENO: WARNING: $ac_header: section \"Present But Cannot Be Compiled\"" >&5
|
|
+$as_echo "$as_me: WARNING: $ac_header: section \"Present But Cannot Be Compiled\"" >&2;}
|
|
+ { $as_echo "$as_me:$LINENO: WARNING: $ac_header: proceeding with the preprocessor's result" >&5
|
|
+$as_echo "$as_me: WARNING: $ac_header: proceeding with the preprocessor's result" >&2;}
|
|
+ { $as_echo "$as_me:$LINENO: WARNING: $ac_header: in the future, the compiler will take precedence" >&5
|
|
+$as_echo "$as_me: WARNING: $ac_header: in the future, the compiler will take precedence" >&2;}
|
|
+ ( cat <<\_ASBOX
|
|
+## ----------------------------------------------- ##
|
|
+## Report this to http://www.squid-cache.org/bugs/ ##
|
|
+## ----------------------------------------------- ##
|
|
+_ASBOX
|
|
+ ) | sed "s/^/$as_me: WARNING: /" >&2
|
|
+ ;;
|
|
+esac
|
|
+{ $as_echo "$as_me:$LINENO: checking for $ac_header" >&5
|
|
+$as_echo_n "checking for $ac_header... " >&6; }
|
|
+if { as_var=$as_ac_Header; eval "test \"\${$as_var+set}\" = set"; }; then
|
|
+ $as_echo_n "(cached) " >&6
|
|
+else
|
|
+ eval "$as_ac_Header=\$ac_header_preproc"
|
|
+fi
|
|
+ac_res=`eval 'as_val=${'$as_ac_Header'}
|
|
+ $as_echo "$as_val"'`
|
|
+ { $as_echo "$as_me:$LINENO: result: $ac_res" >&5
|
|
+$as_echo "$ac_res" >&6; }
|
|
+
|
|
+fi
|
|
+if test `eval 'as_val=${'$as_ac_Header'}
|
|
+ $as_echo "$as_val"'` = yes; then
|
|
+ cat >>confdefs.h <<_ACEOF
|
|
+#define `$as_echo "HAVE_$ac_header" | $as_tr_cpp` 1
|
|
+_ACEOF
|
|
+
|
|
+else
|
|
+ { { $as_echo "$as_me:$LINENO: error: neither <gssapi/gssapi.h> nor <gssapi.h> found" >&5
|
|
+$as_echo "$as_me: error: neither <gssapi/gssapi.h> nor <gssapi.h> found" >&2;}
|
|
+ { (exit 1); exit 1; }; }
|
|
+
|
|
+fi
|
|
+
|
|
+done
|
|
+
|
|
+ fi
|
|
+fi
|
|
+
|
|
+# Check whether --enable-ntlm-fail-open was given.
|
|
+if test "${enable_ntlm_fail_open+set}" = set; then
|
|
+ enableval=$enable_ntlm_fail_open; if test "$enableval" = "yes" ; then
|
|
+
|
|
+cat >>confdefs.h <<\_ACEOF
|
|
+#define NTLM_FAIL_OPEN 1
|
|
+_ACEOF
|
|
+
|
|
+ fi
|
|
+
|
|
+fi
|
|
+
|
|
+
|
|
+EXTERNAL_ACL_HELPERS=
|
|
+# Check whether --enable-external-acl-helpers was given.
|
|
+if test "${enable_external_acl_helpers+set}" = set; then
|
|
+ enableval=$enable_external_acl_helpers; case "$enableval" in
|
|
+ yes)
|
|
+ echo "ERROR: --enable-external-acl-helpers requires an argument"
|
|
+ exit 1
|
|
+ ;;
|
|
+ no)
|
|
+ ;;
|
|
+ *)
|
|
+ EXTERNAL_ACL_HELPERS="`echo $enableval| sed -e 's/,/ /g;s/ */ /g'`"
|
|
+ esac
|
|
+
|
|
+fi
|
|
+
|
|
+if test -n "$EXTERNAL_ACL_HELPERS"; then
|
|
+ for helper in $EXTERNAL_ACL_HELPERS; do
|
|
+ if test -f $srcdir/helpers/external_acl/$helper/Makefile.in; then
|
|
+ :
|
|
+ else
|
|
+ echo "ERROR: external acl helper $helper does not exists"
|
|
+ exit 1
|
|
+ fi
|
|
+ done
|
|
+ echo "External acl helpers built: $EXTERNAL_ACL_HELPERS"
|
|
+fi
|
|
+
|
|
+
|
|
+
|
|
+if test "$require_sasl" = "yes"; then
|
|
+
|
|
|
|
for ac_header in sasl/sasl.h sasl.h
|
|
do
|
|
--- include/autoconf.h.in.orig 2008-06-05 02:18:07.000000000 +0200
|
|
+++ include/autoconf.h.in 2008-07-06 17:45:05.000000000 +0200
|
|
@@ -161,6 +161,12 @@
|
|
/* Define to 1 if you have the <grp.h> header file. */
|
|
#undef HAVE_GRP_H
|
|
|
|
+/* Define to 1 if you have the <gssapi/gssapi.h> header file. */
|
|
+#undef HAVE_GSSAPI_GSSAPI_H
|
|
+
|
|
+/* Define to 1 if you have the <gssapi.h> header file. */
|
|
+#undef HAVE_GSSAPI_H
|
|
+
|
|
/* Define to 1 if you have the `initgroups' function. */
|
|
#undef HAVE_INITGROUPS
|
|
|
|
--- helpers/negotiate_auth/squid_kerb_auth/Makefile.in.orig 2007-11-12 02:14:15.000000000 +0100
|
|
+++ helpers/negotiate_auth/squid_kerb_auth/Makefile.in 2008-07-06 17:45:05.000000000 +0200
|
|
@@ -130,6 +130,18 @@
|
|
INSTALL_PROGRAM = @INSTALL_PROGRAM@
|
|
INSTALL_SCRIPT = @INSTALL_SCRIPT@
|
|
INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
|
|
+#-L$(top_builddir)/lib -lmiscutil $(XTRA_LIBS)
|
|
+
|
|
+# HEIMDAL
|
|
+#KERBINC = -DHEIMDAL -I/usr/include/heimdal
|
|
+#KERBLIBS = -lgssapi -lkrb5 -lcom_err -lasn1 -lroken
|
|
+
|
|
+# MIT
|
|
+#KERBINC =
|
|
+#KERBLIBS = -lgssapi_krb5 -lkrb5 -lcom_err
|
|
+KERBINC = -DHEIMDAL @KERBINC@
|
|
+KERBLIBS = @KERBLIBS@
|
|
+KRB5CONFIG = @KRB5CONFIG@
|
|
LDFLAGS = @LDFLAGS@
|
|
LIBDLMALLOC = @LIBDLMALLOC@
|
|
LIBOBJS = @LIBOBJS@
|
|
@@ -265,15 +277,6 @@
|
|
squid_kerb_auth_SOURCES = $(SOURCE) $(SPNEGO)
|
|
#-I$(top_srcdir)/include -I$(top_srcdir)/src
|
|
LDADD = $(KERBLIBS)
|
|
-#-L$(top_builddir)/lib -lmiscutil $(XTRA_LIBS)
|
|
-
|
|
-# HEIMDAL
|
|
-#KERBINC = -DHEIMDAL -I/usr/include/heimdal
|
|
-#KERBLIBS = -lgssapi -lkrb5 -lcom_err -lasn1 -lroken
|
|
-
|
|
-# MIT
|
|
-KERBINC =
|
|
-KERBLIBS = -lgssapi_krb5 -lkrb5 -lcom_err
|
|
all: all-am
|
|
|
|
.SUFFIXES:
|
|
--- helpers/negotiate_auth/squid_kerb_auth/squid_kerb_auth.c.orig 2008-02-24 20:18:53.000000000 +0100
|
|
+++ helpers/negotiate_auth/squid_kerb_auth/squid_kerb_auth.c 2008-07-06 17:45:05.000000000 +0200
|
|
@@ -24,6 +24,7 @@
|
|
/*
|
|
* Hosted at http://sourceforge.net/projects/squidkerbauth
|
|
*/
|
|
+#include "config.h"
|
|
#include <string.h>
|
|
#include <stdio.h>
|
|
#include <stdlib.h>
|
|
@@ -31,6 +32,7 @@
|
|
#include <unistd.h>
|
|
#include <time.h>
|
|
#include <sys/time.h>
|
|
+#include <sys/param.h>
|
|
|
|
#include "base64.h"
|
|
#ifndef HAVE_SPNEGO
|
|
@@ -47,7 +49,11 @@
|
|
#define PROGRAM "squid_kerb_auth"
|
|
|
|
#ifdef HEIMDAL
|
|
+#ifdef HAVE_GSSAPI_GSSAPI_H
|
|
+#include <gssapi/gssapi.h>
|
|
+#else
|
|
#include <gssapi.h>
|
|
+#endif
|
|
#define gss_nt_service_name GSS_C_NT_HOSTBASED_SERVICE
|
|
#else
|
|
#include <gssapi/gssapi.h>
|
|
--- helpers/negotiate_auth/squid_kerb_auth/spnegohelp/derparse.c.orig 2007-05-15 01:36:32.000000000 +0200
|
|
+++ helpers/negotiate_auth/squid_kerb_auth/spnegohelp/derparse.c 2009-03-28 17:21:54.000000000 +0100
|
|
@@ -22,12 +22,19 @@
|
|
//
|
|
/////////////////////////////////////////////////////////////
|
|
|
|
+#include "config.h"
|
|
#include <stdlib.h>
|
|
#include <stdio.h>
|
|
#include <memory.h>
|
|
#include "spnego.h"
|
|
#include "derparse.h"
|
|
|
|
+#ifdef WORDS_BIGENDIAN
|
|
+#undef __LITTLE_ENDIAN__
|
|
+#else
|
|
+#define __LITTLE_ENDIAN__ 1
|
|
+#endif
|
|
+
|
|
//
|
|
// The GSS Mechanism OID enumeration values (SPNEGO_MECH_OID) control which offset in
|
|
// the array below, that a mechanism can be found.
|