freebsd-ports/www/squid/files/patch-tools-Makefile.in
Martin Wilke 270caa4970 - Fix a mistake I (the maintainer) had introduced regarding the
installation of the cachemgr.conf.default file: instead of explicitly
installing it I thought it would be enough to change an automake
variable that served an entirely different purpose, namely
hardcoding the path to the configuration in the cachemgr.cgi
binary.
- While at it: remove a no longer needed .sh reference from
files/pkg-message.in.
- Set PORTREVISION to 1 because the hardcoded name of the default
configuration file has changed within cachemgr.cgi.

PR:		123573
Submitted by:	Thomas-Martin Seck <tmseck@web.de> (maintainer)
2008-05-16 12:27:17 +00:00

11 lines
572 B
Text

--- tools/Makefile.in.orig 2008-05-10 18:39:20.000000000 +0200
+++ tools/Makefile.in 2008-05-10 18:40:02.000000000 +0200
@@ -791,6 +791,8 @@
$(OBJS): $(top_srcdir)/include/version.h ../include/autoconf.h
install-data-local:
+ @echo "$(INSTALL_DATA) $(srcdir)/cachemgr.conf $(DESTDIR)$(DEFAULT_CACHEMGR_CONFIG).default"; \
+ $(INSTALL_DATA) $(srcdir)/cachemgr.conf $(DESTDIR)$(DEFAULT_CACHEMGR_CONFIG).default;
@if test -f $(DESTDIR)$(DEFAULT_CACHEMGR_CONFIG) ; then \
echo "$@ will not overwrite existing $(DESTDIR)$(DEFAULT_CACHEMGR_CONFIG)" ; \
else \