5440e107ef
I'm not entirely sure why it compiles on 7.x/8.x, but nevertheless, the autoconf-specific parts to these patches absolutely need to go upstream.
214 lines
7 KiB
Text
214 lines
7 KiB
Text
--- ./source3/configure.in.orig 2010-05-10 07:58:53.000000000 -0500
|
|
+++ ./source3/configure.in 2010-09-24 16:43:52.000000000 -0500
|
|
@@ -212,12 +212,2 @@
|
|
|
|
-AC_ARG_ENABLE(dmalloc, [AS_HELP_STRING([--enable-dmalloc], [Enable heap debugging [default=no]])])
|
|
-
|
|
-if test "x$enable_dmalloc" = xyes
|
|
-then
|
|
- AC_DEFINE(ENABLE_DMALLOC, 1, [Define to turn on dmalloc debugging])
|
|
- AC_DEFINE(DMALLOC_FUNC_CHECK, 1,
|
|
- [Define to check invariants around some common functions])
|
|
- LIBS="$LIBS -ldmalloc"
|
|
-fi
|
|
-
|
|
#################################################
|
|
@@ -699,3 +689,8 @@
|
|
AC_CHECK_HEADERS(sys/mman.h sys/filio.h sys/priv.h sys/shm.h string.h strings.h stdlib.h)
|
|
-AC_CHECK_HEADERS(sys/mount.h sys/vfs.h sys/fs/s5param.h sys/filsys.h termios.h termio.h)
|
|
+AC_CHECK_HEADERS(sys/mount.h, [], [],
|
|
+[[#ifdef HAVE_SYS_PARAM_H
|
|
+#include <sys/param.h>
|
|
+#endif
|
|
+]])
|
|
+AC_CHECK_HEADERS(sys/vfs.h sys/fs/s5param.h sys/filsys.h termios.h termio.h)
|
|
AC_CHECK_HEADERS(sys/termio.h sys/statfs.h sys/dustat.h sys/statvfs.h stdarg.h)
|
|
@@ -783,6 +778,6 @@
|
|
|
|
- ac_save_CFLAGS=$CFLAGS
|
|
- ac_save_LDFLAGS=$LDFLAGS
|
|
+ ac_save_PRINT_CPPFLAGS=$CPPFLAGS
|
|
+ ac_save_PRINT_LDFLAGS=$LDFLAGS
|
|
ac_save_PRINT_LIBS=$PRINT_LIBS
|
|
- CFLAGS="$CFLAGS `$CUPS_CONFIG --cflags`"
|
|
+ CPPFLAGS="$CPPFLAGS `$CUPS_CONFIG --cflags`"
|
|
LDFLAGS="$LDFLAGS `$CUPS_CONFIG --ldflags`"
|
|
@@ -796,4 +791,4 @@
|
|
AC_MSG_WARN([cups-config around but cups-devel not installed])
|
|
- CFLAGS=$ac_save_CFLAGS
|
|
- LDFLAGS=$ac_save_LDFLAGS
|
|
+ CPPFLAGS=$ac_save_PRINT_CPPFLAGS
|
|
+ LDFLAGS=$ac_save_PRINT_LDFLAGS
|
|
PRINT_LIBS=$ac_save_PRINT_LIBS
|
|
@@ -1751,5 +1746,2 @@
|
|
|
|
-AC_MSG_CHECKING([NSSSONAMEVERSIONSUFFIX])
|
|
-AC_MSG_RESULT([$NSSSONAMEVERSIONSUFFIX])
|
|
-
|
|
AC_CACHE_CHECK([whether building shared libraries actually works],
|
|
@@ -3963,6 +3955,6 @@
|
|
# first test for Active Directory support being enabled
|
|
- #if test x"$with_ads_support" = x"no"; then
|
|
- # AC_MSG_ERROR(Active Directory support is required to enable DNS Update support)
|
|
- # with_dnsupdate_support=no
|
|
- #fi
|
|
+ if test x"$with_ads_support" = x"no"; then
|
|
+ AC_MSG_ERROR(Active Directory support is required to enable DNS Update support)
|
|
+ with_dnsupdate_support=no
|
|
+ fi
|
|
##################################################################
|
|
@@ -4183,11 +4175,47 @@
|
|
AC_MSG_ERROR([--with-pam=yes but pam_modules.h not found])
|
|
- fi
|
|
+ fi
|
|
create_pam_modules=no
|
|
- fi
|
|
+ fi
|
|
|
|
if test x"$use_pam" = x"yes"; then
|
|
- AC_DEFINE(WITH_PAM,1,[Whether to include PAM support])
|
|
+ AC_DEFINE(WITH_PAM,1,[Whether to include PAM support])
|
|
AC_DEFINE(HAVE_LIBPAM,1,[Whether libpam is available])
|
|
AUTH_LIBS="$AUTH_LIBS $PAM_LIBS"
|
|
- with_pam_for_crypt=yes
|
|
+ with_pam_for_crypt=yes
|
|
+
|
|
+ AC_VERIFY_C_PROTOTYPE(
|
|
+ [int pam_get_data(const pam_handle_t *pamh, const char *module_data_name, const void **data)],
|
|
+ [return 0;],
|
|
+ [AC_DEFINE(PAM_GET_DATA_ARG3_CONST_VOID_PP, 1, [Whether pam_get_data 3 argument is a const pointer to pointer])],
|
|
+ [
|
|
+ dnl Old OpenPAM declaration
|
|
+ AC_VERIFY_C_PROTOTYPE(
|
|
+ [int pam_get_data(pam_handle_t *pamh, const char *module_data_name, void **data)],
|
|
+ [return 0;],
|
|
+ [AC_DEFINE(PAM_GET_DATA_ARG3_VOID_PP, 1, [Whether pam_get_data 3 argument is a void pointer to pointer])],
|
|
+ [], [
|
|
+ #include <sys/types.h>
|
|
+ #if HAVE_SECURITY_PAM_APPL_H
|
|
+ #include <security/pam_appl.h>
|
|
+ #endif
|
|
+ #if HAVE_PAM_PAM_APPL_H
|
|
+ #include <pam/pam_appl.h>
|
|
+ #endif
|
|
+ #if HAVE_SECURITY_PAM_MODULES_H
|
|
+ #include <security/pam_modules.h>
|
|
+ #endif
|
|
+ ]
|
|
+ )],[
|
|
+ #include <sys/types.h>
|
|
+ #if HAVE_SECURITY_PAM_APPL_H
|
|
+ #include <security/pam_appl.h>
|
|
+ #endif
|
|
+ #if HAVE_PAM_PAM_APPL_H
|
|
+ #include <pam/pam_appl.h>
|
|
+ #endif
|
|
+ #if HAVE_SECURITY_PAM_MODULES_H
|
|
+ #include <security/pam_modules.h>
|
|
+ #endif
|
|
+ ]
|
|
+ )
|
|
|
|
@@ -4201,3 +4229,3 @@
|
|
else
|
|
- AC_MSG_WARN([PAM support detected but PAM MODULES support is missing])
|
|
+ AC_MSG_WARN([PAM support detected but PAM MODULES support is missing])
|
|
fi
|
|
@@ -5256,3 +5284,4 @@
|
|
|
|
-
|
|
+# check for NFSv4 acl
|
|
+AC_CHECK_LIB(sunacl, acl, [ACL_LIBS="$ACL_LIBS -lsunacl"])
|
|
|
|
@@ -5798,2 +5827,3 @@
|
|
../nsswitch/winbind_nss_linux.o"
|
|
+ WINBIND_WINS_NSS_EXTRA_OBJS="../nsswitch/wins_freebsd.o"
|
|
WINBIND_NSS="../nsswitch/nss_winbind.$SHLIBEXT"
|
|
@@ -5890,8 +5920,2 @@
|
|
else
|
|
- if test x"$enable_developer" = x"yes" -a x"$LINK_LIBWBCLIENT" = x"STATIC" ; then
|
|
- BUILD_LIBWBCLIENT_SHARED=no
|
|
- else
|
|
- BUILD_LIBWBCLIENT_SHARED=yes
|
|
- fi
|
|
-
|
|
LIBWBCLIENT_SHARED_TARGET=bin/libwbclient.$SHLIBEXT
|
|
@@ -5900,3 +5924,2 @@
|
|
if test $BLDSHARED = true -a x"$HAVE_WINBIND" = x"yes" -a x"$BUILD_LIBWBCLIENT_SHARED" = x"yes"; then
|
|
- NSS_MODULES="${WINBIND_NSS} ${WINBIND_WINS_NSS}"
|
|
## Only worry about libwbclient if we have shared
|
|
@@ -5922,3 +5945,5 @@
|
|
EXTRA_SBIN_PROGS="$EXTRA_SBIN_PROGS bin/winbindd\$(EXEEXT)"
|
|
- if test $BLDSHARED = true -a x"$create_pam_modules" = x"yes"; then
|
|
+ if test $BLDSHARED = true; then
|
|
+ NSS_MODULES="${WINBIND_NSS} ${WINBIND_WINS_NSS}"
|
|
+ if test x"$create_pam_modules" = x"yes"; then
|
|
PAM_MODULES="$PAM_MODULES pam_winbind"
|
|
@@ -5926,2 +5951,3 @@
|
|
UNINSTALL_PAM_MODULES="uninstallpammodules"
|
|
+ fi
|
|
fi
|
|
@@ -5931,3 +5957,6 @@
|
|
|
|
-AC_CHECK_LIB(pthread, pthread_mutex_lock, [WINBIND_NSS_PTHREAD="-lpthread"
|
|
+AC_MSG_CHECKING([NSSSONAMEVERSIONSUFFIX])
|
|
+AC_MSG_RESULT([$NSSSONAMEVERSIONSUFFIX])
|
|
+
|
|
+AC_CHECK_LIB(pthread, pthread_mutex_lock, [WINBIND_NSS_PTHREAD="${PTHREAD_LIBS}"
|
|
AC_DEFINE(HAVE_PTHREAD, 1, [whether pthread exists])])
|
|
@@ -5936,3 +5965,2 @@
|
|
AC_SUBST(WINBIND_NSS)
|
|
-AC_SUBST(WINBIND_WINS_NSS)
|
|
AC_SUBST(WINBIND_NSS_LDSHFLAGS)
|
|
@@ -5940,4 +5968,7 @@
|
|
AC_SUBST(WINBIND_NSS_EXTRA_LIBS)
|
|
-AC_SUBST(NSSSONAMEVERSIONSUFFIX)
|
|
AC_SUBST(PAM_WINBIND_EXTRA_LIBS)
|
|
+AC_SUBST(WINBIND_WINS_NSS)
|
|
+AC_SUBST(WINBIND_WINS_NSS_EXTRA_OBJS)
|
|
+AC_SUBST(WINBIND_WINS_NSS_EXTRA_LIBS)
|
|
+AC_SUBST(NSSSONAMEVERSIONSUFFIX)
|
|
|
|
@@ -6134,2 +6165,7 @@
|
|
AC_CHECK_HEADERS(sys/statfs.h)
|
|
+AC_CHECK_HEADERS(sys/mount.h, [], [],
|
|
+[[#ifdef HAVE_SYS_PARAM_H
|
|
+#include <sys/param.h>
|
|
+#endif
|
|
+]])
|
|
|
|
@@ -6139,3 +6175,11 @@
|
|
#include <sys/types.h>
|
|
+ #ifdef HAVE_SYS_PARAM_H
|
|
+ #include <sys/param.h>
|
|
+ #endif
|
|
+ #ifdef HAVE_SYS_MOUNT_H
|
|
+ #include <sys/mount.h>
|
|
+ #endif
|
|
+ #ifdef HAVE_SYS_STATFS_H
|
|
#include <sys/statfs.h>
|
|
+ #endif
|
|
int main(void)
|
|
@@ -6451,2 +6495,22 @@
|
|
|
|
+AC_ARG_ENABLE(dmalloc, [AS_HELP_STRING([--enable-dmalloc], [Enable heap debugging [default=no]])])
|
|
+
|
|
+if test "x$enable_dmalloc" = xyes
|
|
+then
|
|
+ AC_DEFINE(ENABLE_DMALLOC, 1, [Define to turn on dmalloc debugging])
|
|
+ AC_DEFINE(DMALLOC_FUNC_CHECK, 1,
|
|
+ [Define to check invariants around some common functions])
|
|
+ LIBS="$LIBS -ldmalloc"
|
|
+fi
|
|
+
|
|
+AC_ARG_ENABLE(dmalloc, [AS_HELP_STRING([--enable-dmalloc], [Enable heap debugging [default=no]])])
|
|
+
|
|
+if test "x$enable_dmalloc" = xyes
|
|
+then
|
|
+ AC_DEFINE(ENABLE_DMALLOC, 1, [Define to turn on dmalloc debugging])
|
|
+ AC_DEFINE(DMALLOC_FUNC_CHECK, 1,
|
|
+ [Define to check invariants around some common functions])
|
|
+ LIBS="$LIBS -ldmalloc"
|
|
+fi
|
|
+
|
|
dnl Remove -L/usr/lib/? from LDFLAGS and LIBS
|