e84a58d2b6
Fix many of the following: CC tclStubInit.c /export/wrkdir/amd64/export/freebsd/git/ports/devel/bitkeeper/work/bk-7.3.3/src/gui/tcltk/tcl/generic/tclStubInit.c:693:5: error: incompatible function pointer types initializing 'int (*)(const mp_int *, const mp_int *)' (aka 'int (*)(const struct mp_int *, const struct mp_int *)') with an expression of type 'int (mp_int *, mp_int *)' (aka 'int (struct mp_int *, struct mp_int *)') [-Wincompatible-function-pointer-types] TclBN_mp_cmp, /* 8 */
10 lines
489 B
Text
10 lines
489 B
Text
--- gui/tcltk/Makefile.orig 2023-08-28 07:06:54.841207000 -0700
|
|
+++ gui/tcltk/Makefile 2023-08-28 07:10:54.236984000 -0700
|
|
@@ -117,6 +117,7 @@
|
|
if [ -n "$$TCLVER" -a -f "$$TCLVER" -a -z "$$FORCE_REBUILD" ]; \
|
|
then gunzip < "$$TCLVER" | tar -xf -; true; \
|
|
else unset CC LD CCXTRA CFLAGS; \
|
|
+ export CFLAGS=-Wno-incompatible-function-pointer-types; \
|
|
MAKEFLAGS=`echo "$$MAKEFLAGS" | sed 's/ -- .*//'`; \
|
|
$(MAKE) Q=$(Q) populate ; \
|
|
$(MAKE) Q=$(Q) bin/tclsh$(EXE) || exit 1; \
|