0a56d0ccd8
debugger and the browser's JavaScript. There's no compiling of code to JavaScript to view it in the browser. You can use the same edit-refresh-view cycle you're used to with JavaScript, while at the same time inspect variables, set breakpoints, and utilize all the other debugger tools available to you with Java. And because GWT's development mode is now in the browser itself, you can use tools like Firebug and Inspector as you code in Java. PR: ports/143042 Submitted by: Jonathan Chen <jonc at chen.org.nz>
26 lines
694 B
Makefile
26 lines
694 B
Makefile
diff -u /tmp/gwt-plugins-release-2.0/config.mk config.mk
|
|
--- /tmp/gwt-plugins-release-2.0/config.mk 2010-01-19 08:52:18.000000000 +1300
|
|
+++ ./config.mk 2010-01-11 14:41:49.000000000 +1300
|
|
@@ -32,6 +32,9 @@
|
|
FLAG32BIT=32
|
|
|
|
# Figure out 64-bit platforms, canonicalize ARCH and MARCH
|
|
+ifeq ($(ARCH),amd64)
|
|
+FLAG32BIT=64
|
|
+endif
|
|
ifeq ($(ARCH),x86_64)
|
|
FLAG32BIT=64
|
|
endif
|
|
@@ -76,6 +79,12 @@
|
|
endif
|
|
|
|
# Set OS as well as CFLAGS, CXX, and other common make variables
|
|
+ifeq ($(shell uname),FreeBSD)
|
|
+OS=freebsd
|
|
+BASECFLAGS= -g -O2 -fPIC $(INC) -rdynamic
|
|
+ARCHCFLAGS=-m$(FLAG32BIT)
|
|
+ALLARCHCFLAGS=$(ARCHCFLAGS)
|
|
+endif
|
|
ifeq ($(shell uname),Linux)
|
|
OS=linux
|
|
BASECFLAGS= -g -O2 -fPIC $(INC) -rdynamic
|